Bug #72207

Epic #72584: sysext:impexp

Files missing in import/export

Added by Prakash A Bhat almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Import/Export (T3D)
Target version:
-
Start date:
2015-12-14
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

This is with reference to an old issue:
https://forge.typo3.org/issues/49227

I tested this on a 6.2.15 setup.

We had 3 existing domains, we had to do a 4th domain, add content and do a t3d export of the branch.

Well, without any error message about the missing FAL images, Typo3 did do the import/export!

At the other end, the references to sys_file was all wrong.

On analyzing deeper, I see that during the process, the uid_local in "sys_file_reference" did not get updated, instead it tried to use the same value as in the source. Instead this should have used the latest "uid" of the sys_file on the destination.


Related issues

Related to TYPO3 Core - Task #49227: Files missing in import/export Closed 2013-06-18
Duplicates TYPO3 Core - Bug #67188: Wrong FAL References after Import Closed 2015-05-29

History

#1 Updated by Anja Leichsenring over 3 years ago

  • Parent task set to #72584

#2 Updated by Anja Leichsenring over 3 years ago

  • Sprint Focus set to On Location Sprint

#3 Updated by Nicole Cordes over 3 years ago

  • Sprint Focus deleted (On Location Sprint)

#4 Updated by Christian Kuhn over 1 year ago

  • Duplicates Bug #67188: Wrong FAL References after Import added

#5 Updated by Christian Kuhn over 1 year ago

  • Status changed from New to Closed

resolved as dupe of #67188

Also available in: Atom PDF