Bug #73059

Epic #84751: Save Button Gate

Back to the future: Please remove dropdown-list torture from Save buttons

Added by Paul A. Auwehla over 4 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
Won't have this time
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2016-02-01
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Please remove dropdown-itemlist from the elements "Save and new" and "Save and view" "Save and close" etc from all this save fields in the backend.
Please make all Save-icons visible all time like in older typo3-versions again.

Not only in touch sreens and in mobile ready responsive webpages when front-end editing
but in the desktop backend too, its a torture-like procedure to press the save button, wait for the list-options
and then select the option just to save and close or save and view or something like this in every and all freshly edited content-elements and backend-forms.

The dorpdown-list is beautiful and optical very fine -
but in practical use for editors its a pain.


Related issues

Related to TYPO3 Core - Feature #77001: Make primary Save Split Button configurable Rejected 2016-07-10

History

#1 Updated by Mathias Schreiber over 4 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Mathias Schreiber

We had this discussion quite often until now.

Here is the reasoning:
The icons were the same pain. Editors claimed to be confused with the icons.
The switch to a flat icon scheme makes this even more difficult.
Thus, you need a textual representation of what the button actually does.
Given the amount is possibilities (you are aware there are 6 save-actions?) showing them all with icon and text is not feasible (especially given the rather long action names like "Save but do not finish translation").

If you have an idea how to solve these problems, by all means, give us feedback what should be done.

#3 Updated by Paul A. Auwehla over 4 years ago

Thank you very much for your fast reaction.
rx_unrollsavebuttons is exactly what I had in mind.

Please allow some reflections about the icons:

() Not knowing the icons and to learn their meaning takes about 1 minute per editor per livetime of this editor
() Two touches or clicks takes more than 1 minute per day for some years of the lifetime of the editor.

MouseOver hints are established since some years in typo3. There is no need to establish dropdown text beside icons in this case.
Perhaps there could be a configuration value as a switch in typo3 like there a hundreds up to now offering the new doubleclick saving as an option.
(LibreOffice for ex. still has the old fashioned but ergonomic Save SaveAs buttons)

;-))
Replacing the outdated disk-icons would do a good job, too.
Young editors will not remember what these floppy-discs icons could be ;-))
Anybody out there having a floppy-drive on his tablet, phone, notebook or desktop?
(Its just like youngsters will not remember what this black-bone-icon near a phone number could be good for ,-))

#4 Updated by Riccardo De Contardi about 4 years ago

There are 2 different extensions that reverts back the separate save buttons:

https://typo3.org/extensions/repository/view/wh_save_buttons

https://typo3.org/extensions/repository/view/rx_unrollsavebuttons

I refrain from closing this, but in my opinion it's time to do, because there are multiple alternatives for people that don't like the dropdown.

About replacing the diskette icon... I think that the cig-ux channel on slack could be the right place to discuss this topic (or open an issue on https://github.com/wmdbsystems/T3.Icons )

#5 Updated by Anja Leichsenring over 3 years ago

  • Status changed from Needs Feedback to Rejected
  • Assignee deleted (Mathias Schreiber)
  • Priority changed from Should have to Won't have this time

as explained by Mattes already, there is no way to satisfy all wishes out there. We decided for the split button magic in the core, and it will stay for the time being. If you dislike this behavior, please consider one of the proposed TER extensions.

I close this ticket now as it will lead nowhere to keep it open.

#6 Updated by Rens Admiraal about 2 years ago

#7 Updated by Patrick Broens about 2 years ago

  • Parent task set to #84751

Also available in: Atom PDF