Bug #75014

l18n_cfg not respected in fluid_styled_contents of type special menu

Added by Daniel Siepmann over 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid Styled Content
Start date:
2016-03-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

The result
Pages in default location are shown in menus, even if they should not.

How to reproduce
Create a page in default language, select option "Hide default translation of page" under "Behaviour".
Create a content element of kind "special menus" and select the created page. Create the element in default language.
The page will be shown and link is broken as page should not be visible because it's not available in default language.
https://docs.typo3.org/typo3cms/FrontendLocalizationGuide/BasicSetupOfALocalizedWebsite/LocalizationOverviewOfThePageTree/Index.html#hiding-default-translation-of-pages

For our own implementation we had to add the following SQL to fix the issue:

        if ($this->arguments[static::ARGUMENT_TABLE] === 'pages') {
            $where .= ' AND pages.l18n_cfg != 1';
        }


Related issues

Related to TYPO3 Core - Bug #85063: \TYPO3\CMS\Frontend\Typolink\PageLinkBuilder::build doesn't honor l18n_cfg settingsClosed2018-05-22

Actions
Related to TYPO3 Core - Bug #82122: Typo3DbBackend::doLanguageAndWorkspaceOverlay ignores pages l18n_cfgClosed2017-08-17

Actions

Also available in: Atom PDF