Bug #75460

Replacement of pictures of an image CE in workspaces

Added by Alexander Krist over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2016-04-08
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello,

there is a bug with FAL images in workspaces.
I can't see the added images in edit mode after i deleted the original image in workspace.

What i've done

1. Create an image CE with an picture. (screenshot1.png)
2. Switch to a Workspace (screenshot2.png)
3. Edit the image CE (screenshot3.png)
4. Delete the picture from live workspace (screenshot4.png)
5. Add new picture(s) (screenshot4.png)
6. Save

I can see the picture(s) in the workspace preview view.
I can see the picture(s) in the BE page module (screenshot5.png)
But i can't see the picture(s) when i like to edit the image CE. (screenshot6.png)
I can add new picutres but
I can't delete the added pictures because I can't see them.

screenshot1.png View (59.6 KB) Alexander Krist, 2016-04-08 13:10

screenshot2.png View (42.1 KB) Alexander Krist, 2016-04-08 13:10

screenshot3.png View (54.3 KB) Alexander Krist, 2016-04-08 13:10

screenshot4.png View (71.2 KB) Alexander Krist, 2016-04-08 13:10

screenshot5.png View (58 KB) Alexander Krist, 2016-04-08 13:10

screenshot6.png View (54.1 KB) Alexander Krist, 2016-04-08 13:10


Related issues

Duplicates TYPO3 Core - Bug #76012: Swapped page "Media" image file in workspace not shown unless published Closed 2016-05-02

History

#1 Updated by Armin Vieweg over 3 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Alexander Krist

Sure that this is DCE related?
It looks like a normal content element and a bug in TYPO3 core. Probably the "inline record" part, which is responsible to get FAL relations.

Can you confirm that it is also buggy with regular content elements?
If yes, I move this ticket to TYPO3 CMS project for you.

Thanks for this detailed ticket, with screenshots and clear description!

#2 Updated by Alexander Krist over 3 years ago

You are right. I don't know why I opened it here. So how can I move it to Core?

#3 Updated by Armin Vieweg over 3 years ago

  • Status changed from Needs Feedback to New
  • Assignee deleted (Alexander Krist)

#4 Updated by Armin Vieweg over 3 years ago

  • Project changed from Dynamic Content Elements (DCE) to TYPO3 Core

#5 Updated by Armin Vieweg over 3 years ago

I've moved the ticket to core for you.

#6 Updated by Alexander Krist over 3 years ago

Thanks

#7 Updated by Christoph Domin over 3 years ago

We have the same problem with a Typo3 7.6.4 Installation.

#8 Updated by Riccardo De Contardi over 3 years ago

  • Category set to Workspaces
  • Is Regression set to No

#9 Updated by Andreas Allacher over 3 years ago

The issue is most likely that in \TYPO3\CMS\Backend\Form\FormDataProvider\TcaInline class, the method getWorkspacedUids
returns an empty array, if there is any deleted record.

However, instead it should just continue the foreach loop and not add the record to the array.

#10 Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48608

#11 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48608

#12 Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48608

#13 Updated by Gerrit Code Review over 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48608

#14 Updated by Sascha Schieferdecker about 3 years ago

Does this patch have a chance to get merged? We are using the patched version for several months in project affected by this issue and it solves the problem - we did not notice adverse side effects.

#15 Updated by Susanne Moog about 3 years ago

I also wrote it at the review: The main bug was fixed by #76012 3 months ago, question is whether this patch is still necessary.

#16 Updated by Oliver Hader almost 3 years ago

  • Status changed from Under Review to Closed

Change is not required anymore for disappeared children in form-engine in workspace context

#17 Updated by Andreas Allacher almost 3 years ago

The mentioned bugfix doesn't fix the following, quoting from review.

The other two lines are necessary to ensure deleted files in translations are not shown inside workspaces.
If you now have two languages 
and images in a content-element in the non-default language.
Now if you delete one of those images and save the content element in the non-default language, you will see that the image is still visible.
That is why the other tow lines existed. Not sure if that hasn't been fixed with another ticket.
If not, we should create a new ticket for that and move the corresponding changes there.

If not, we should create another ticket for that and move the code changes there.

Also available in: Atom PDF