Bug #76410

Link wizard does not fill hidden field of Flexform input field

Added by Andreas Wolf over 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2016-05-31
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When using a link wizard on a FlexForm input field, the wizard does not fill the hidden field, leading to the selected value not being saved, despite it being displayed in the visible form field.


Related issues

Related to TYPO3 Core - Bug #70602: Page link wizard does not save selected page uid Closed 2015-10-12
Related to TYPO3 Core - Bug #72639: Core-bug: Page link wizard does not save selected page uid Closed 2016-01-11

History

#1 Updated by Alexander Schnitzler over 2 years ago

Any news here? I can confirm this is still an issue with TYPO3 7.6.16. Probably simply some js callback missing that updates the hidden field.

I am sure it worked in older versions (before 7.6), so I'd consider this to be a regression.

#2 Updated by Thomas Off over 2 years ago

Could be related to #70602

#3 Updated by Mona Muzaffar over 2 years ago

  • Related to Bug #70602: Page link wizard does not save selected page uid added

#4 Updated by Mona Muzaffar over 2 years ago

  • Related to Bug #72639: Core-bug: Page link wizard does not save selected page uid added

#5 Updated by Mona Muzaffar over 2 years ago

  • Status changed from Accepted to Needs Feedback

If you are using wizard_element_browser, it could be related to #70602 and #72639.
As mentioned in the related tickets using wizard_link instead of wizard_element_browser might solve the issue.

#6 Updated by Riccardo De Contardi over 2 years ago

Moreover, as written on https://forge.typo3.org/issues/70602#note-13, if the extension "compatibility6" is activated, that could be the cause of the issue.

#7 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (Candidate for patchlevel)

90 days without feedback > closing.

If you think that this is the wrong decision or experience the issue again, please reopen it or open a new issue with a reference to this one. Thank you.

Also available in: Atom PDF