Bug #72639

Core-bug: Page link wizard does not save selected page uid

Added by Roman Crescente over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Backend API
Start date:
2016-01-11
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

(From: https://forge.typo3.org/issues/70602)
Still open in 7.6.2
The pid dont changes when there is a "page" selected for example:

1. open an element
2. select page with id 1, save.
3. reopen (now we have pid 1)select page with id 2
4. click "save" and when you click on save it jumps back to "id" 1 instead 2..

(in the html the hidden field has the old value)
when I change the Linhandler-TYPE to for example "file:2" then it works. just on the same type it dont changes

changes
page to page
file to file
...
don't works.


Related issues

Related to TYPO3 Core - Bug #70602: Page link wizard does not save selected page uid Closed 2015-10-12
Related to TYPO3 Core - Bug #76410: Link wizard does not fill hidden field of Flexform input field Closed 2016-05-31

History

#1 Updated by Alexander Opitz over 3 years ago

  • Category set to Backend API
  • Target version set to Candidate for patchlevel

Please, if you create a new issue, do not add watchers wildly. This will only help you to get rejected.

#2 Updated by Andre Koller over 3 years ago

Same here.

my TCA:

'link' => array(
            'label' => 'LLL:EXT:cms/locallang_ttc.xlf:header_link',
            'exclude' => 1,
            'config' => array(
                'type' => 'input',
                'size' => '50',
                'max' => '256',
                'eval' => 'trim',
                'wizards' => array(
                    'link' => array(
                        'type' => 'popup',
                        'title' => 'LLL:EXT:cms/locallang_ttc.xlf:header_link_formlabel',
                        'icon' => 'link_popup.gif',
                        'module' => array(
                            'name' => 'wizard_element_browser',
                            'urlParameters' => array(
                                'mode' => 'wizard'
                            )
                        ),
                        'JSopenParams' => 'height=800,width=600,status=0,menubar=0,scrollbars=1'
                    )
                ),
                'softref' => 'typolink'
            )
        ),

#3 Updated by Andre Koller over 3 years ago

Works with wizard_link instead of wizard_element_browser

'link' => array(
            'label' => 'LLL:EXT:cms/locallang_ttc.xlf:header_link',
            'exclude' => 0,
            'config' => array(
                'type' => 'input',
                'size' => '50',
                'max' => '256',
                'eval' => 'trim,required',
                'wizards' => array(
                    '_PADDING' => 2,
                    'link' => array(
                        'type' => 'popup',
                        'title' => 'Link',
                        'icon' => 'EXT:backend/Resources/Public/Images/FormFieldWizard/wizard_link.gif',
                        'module' => array(
                            'name' => 'wizard_link',
                        ),
                        'JSopenParams' => 'height=800,width=600,status=0,menubar=0,scrollbars=1'
                    )
                ),
                'softref' => 'typolink'
            )
        ),

#4 Updated by Jo Hasenau over 3 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Jo Hasenau

Does this mean that the bug is fixed, or is it necessary to fix wizard_element_browser?
So is the actual "bug" that you have to use a nother wizard for that purpose, or is that particular wizard really broken?

#5 Updated by Andreas Wolf over 3 years ago

  • Status changed from Needs Feedback to Closed

This is intended behaviour:

Reference to "wizard_element_browser" was migrated to new "wizard_link" for field "header_link" in TCA table "tt_content"

#6 Updated by Jo Hasenau over 3 years ago

Well - the old wizard was broken and is now replaced automagically with the other wizard. So actually it was not intended, but we won't fix it anymore.

#7 Updated by Andreas Moeller about 3 years ago

My problem was the extension "compatibility6". I disabled it, and it worked again.

#8 Updated by Mona Muzaffar over 2 years ago

  • Related to Bug #76410: Link wizard does not fill hidden field of Flexform input field added

Also available in: Atom PDF