Bug #77469

Duplicates of new frontend- and backenduser record when using IE11

Added by Julian Hofmann almost 4 years ago. Updated 6 months ago.

Status:
New
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2016-08-10
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
JavaScript
Complexity:
Is Regression:
No
Sprint Focus:

Description

Creating an new Website User (fe_user) with IE11 results in two new records.

Web -> List: "new record", entering data -> "save and close"

Tested with IE11 in TYPO3 7.6.0, 7.6.4, 7.6.10 and 8.2.1

Bildschirmfoto 2019-12-11 um 10.06.30.png View (121 KB) Florian Wessels, 2019-12-11 10:06


Related issues

Related to TYPO3 Core - Bug #77729: Save Button must be disabled until formengine form is fully loaded Closed 2016-09-01
Duplicated by TYPO3 Core - Bug #77517: feuser is created twice in IE11 Closed 2016-08-16

History

#1 Updated by König David over 3 years ago

I can confirm this Bug, and add some more Informations:

If you open the Developer-Console in IE11, the problem no longer occurs, also if you now close the Console.
If you Restart the Browser, the problem occurs again.

#2 Updated by Florian Wessels over 3 years ago

  • Subject changed from Duplicates of new frontenduser record when using IE11 to Duplicates of new frontend- and backenduser record when using IE11

Same behaviour for BE-Users (list and module)...

#3 Updated by Riccardo De Contardi over 3 years ago

  • Category set to Backend User Interface

#4 Updated by Markus Timtner over 3 years ago

Hi there, I can't confirm this behaviour,
it doesn't occur with me in IE11, or in Edge.

I tested this with single click and double click on save&close.

#5 Updated by Markus Timtner over 3 years ago

...but I can confirm this behavior when clicking: "save and create a new record"!

#6 Updated by Markus Timtner over 3 years ago

Now I can cofirm this behavior for "save&close", too.

This behaviour isn't related to #77942, since I tested it with the patch applied :/

#7 Updated by Riccardo De Contardi about 3 years ago

I can confirm the issue with IE11 11.0.9600.18537 on Windows 7 (Save & Close)

#8 Updated by Benjamin Kott almost 3 years ago

  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
  • Sprint Focus set to On Location Sprint

#9 Updated by Oliver Hader almost 3 years ago

  • Tags set to JavaScript

#10 Updated by Oliver Hader almost 3 years ago

  • Status changed from Accepted to In Progress
  • Assignee set to Sven Laser

Sven is working on this issue during the next few days...

#11 Updated by Stephan Großberndt almost 3 years ago

I can confirm the issue too.

#12 Updated by Anja Leichsenring over 2 years ago

  • Sprint Focus deleted (On Location Sprint)

#13 Updated by Gregor Schreier almost 2 years ago

This issue is still there in LTS 8 latest Release. Annoying bug, especially in the corporate environment if the browser is specified.

Why is there a token for check if an request is valid but not validated against double submit. Double-Submits could be avoided by storing formTokens in BE-Session and Unsetting this tokens after Submits.
This could prevent double submits by design.

gregor

#14 Updated by Riccardo De Contardi over 1 year ago

This issue is no more reproducible on TYPO3 9.5.4

  • I tried with both IE11 and Edge on Windows 10
  • I tried with both creating a fe_user, click on save and then close; and with creating a fe_user, click close and then choose "save and close

#15 Updated by Julian Hofmann over 1 year ago

Can confirm: this issue is no more reproducible on TYPO3 9.5.4 (Win7, SP1; IE11)

In my opinion, the issue could be closed.
The bug is a little bit annoying, but not security relevant. TYPO3 v8 is already in "Priority bugfixes"-mode, in v9 it is fixed/not reproducible.

#16 Updated by Riccardo De Contardi 9 months ago

  • Status changed from In Progress to Closed
  • Assignee deleted (Sven Laser)

Sorry for my late answer on this one; closing it.

If you think that this is the wrong decision or experience the issue again on recent TYPO3 versions like 9 or 10 please reopen it or ping me.

Thank you.

#17 Updated by Florian Wessels 6 months ago

Unfortunately this is still reproducible on Windows 10 and IE 11 (11.476.18362.0) when clicking the save (not the close) button in the "create new" view.
TYPO3 Version is 9.5.11 (not tested with 10.2)

#18 Updated by Riccardo De Contardi 6 months ago

  • Status changed from Closed to New

Still not able to reproduce it on Windows 10 and IE 11 (11.48.17134.0) - using TYPO3 9.5.11 :(

Could it be some odd race condition?

#19 Updated by Florian Wessels 6 months ago

Seems so, as it is not reproducible every time (I have tried to save five users, only one of them was created twice).
However, I am not sure anything should be done here. It appears to occur only in isolated cases.

Also available in: Atom PDF