Bug #78117

After Update from Typo3 V7 to V8 | PHP GD library gif/png support broken

Added by Markus Weber almost 5 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Start date:
2016-09-30
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
update, installtool
Complexity:
Is Regression:
No
Sprint Focus:

Description

After updating Typo3 V7.6.11 to V8.3.1 the Tnstalltool throws the errors

PHP GD library gif support broken
PHP GD library png support broken

The tool also recommends to use cUrl or to set allow_fopen_url to 1.

The settings for cUrl are not avaiable in the Tool, manuall settings are ignored.

The GD-Library-Bug is "fixed" after setting allow_fopen_url to 1 via php.ini

I think if you fix the cUrl-Bug the GD bug is also solved


Files

patch.diff (1.44 KB) patch.diff Horst Wiederhold, 2017-05-10 16:32

Related issues

Related to TYPO3 Core - Bug #69495: System environment check is not standaloneClosedMathias Brodala2015-09-03

Actions
#1

Updated by Nicole Cordes almost 5 years ago

  • Status changed from New to Needs Feedback

Hi Markus,

can you please add some information about your environment?

Can you go to Install > System environment > Scroll down to "Show PHP Info" and copy & paste the section "gd"

The tool also recommends to use cUrl or to set allow_fopen_url to 1.

Can you specify the place where you have seen this recommendation? I haven't found anything in the current master.

#2

Updated by Benni Mack almost 5 years ago

  • Target version changed from 8.4 to 8.5
#3

Updated by Horst Wiederhold almost 5 years ago

In an installation of TYPO3 CMS 8.5.0-dev Master i get the same messages.

GD Support    enabled
GD Version    bundled (2.1.0 compatible)
FreeType Support    enabled
FreeType Linkage    with freetype
FreeType Version    2.5.3
GIF Read Support    enabled
GIF Create Support    enabled
JPEG Support    enabled
libJPEG Version    8
PNG Support    enabled
libPNG Version    1.6.12
WBMP Support    enabled
XBM Support    enabled
Directive    Local Value    Master Value
gd.jpeg_ignore_warning    0    0
#4

Updated by Benni Mack over 4 years ago

  • Target version changed from 8.5 to 8.6
#5

Updated by Sven Juergens over 4 years ago

Same ErrorMessage here.

New Installation on a Domainfactory Account with TYPO3 8.5

#6

Updated by Benni Mack over 4 years ago

  • Target version changed from 8.6 to 8 LTS
#7

Updated by Stefan Froemken over 4 years ago

  • Status changed from Needs Feedback to Accepted

I have the same problem. If you activate warnings in php and remove the @ in front of imagecreatefromgif you will get following warning:

Warning: imagecreatefrompng(): data:// wrapper is disabled in the server configuration by allow_url_fopen=0

IMO the core should not use data:// or http(s):// to test image creation. Please use a local file for testing.

Check.php:1030 on current master:

$imageResource = @imagecreatefromgif('data://image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7');

Stefan

#8

Updated by Markus Klein about 4 years ago

  • Target version changed from 8 LTS to Candidate for patchlevel

Not sure if allow_url_fopen is required in general anyway. I would simply add a test whether this option is set, otherwise skip the test.

#9

Updated by Horst Wiederhold about 4 years ago

In https://forge.typo3.org/issues/69495 there was a change from local files to the use of data:// which requires allow_url_fopen=0.
In current master the following changes from data:// back to local files solved the problem for me:

Check.php:1030

$imageResource = @imagecreatefromgif('data://image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7');

$imageResource = imagecreatefromgif(__DIR__ . '/../../Resources/Public/Images/TestInput/Test.gif');

Check.php:1089
$imageResource = @imagecreatefrompng('data://image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABAQMAAAAl21bKAAAAA1BMVEUAAACnej3aAAAAAXRSTlMAQObYZgAAAApJREFUCNdjYAAAAAIAAeIhvDMAAAAASUVORK5CYII');

$imageResource = @imagecreatefrompng(__DIR__ . '/../../Resources/Public/Images/TestInput/Test.png');

#10

Updated by Horst Wiederhold about 4 years ago

Patch file was missing

#11

Updated by Markus Klein about 4 years ago

  • Related to Bug #69495: System environment check is not standalone added
#12

Updated by Markus Klein about 4 years ago

@Horst: We do not work with patches anymore since a couple of years.
Please push your change request to our review system.
You can find information on the necessary setup in https://docs.typo3.org/typo3cms/ContributionWorkflowGuide/

Don't hesitate to ask, if you need help. Either here, or preferred in Slack.

Thanks.

#13

Updated by Gerrit Code Review over 3 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55300

#14

Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55311

#15

Updated by Tim Lochmüller over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#16

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF