Bug #78134

config.noScaleUp no longer works

Added by Josef Glatz about 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Frontend
Target version:
Start date:
2016-10-03
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:
Stabilization Sprint

Description

Problem/Description

TypoScript config.noScaleUp no longer works since:

Commit 1f4b97454d05d7cb1be2a78b6a6e9f8fad736942
https://review.typo3.org/#/c/42385/
https://forge.typo3.org/issues/43085
https://github.com/TYPO3/TYPO3.CMS/commit/1f4b97454d05d7cb1be2a78b6a6e9f8fad736942#diff-2706384679a406d049dd75857e4c4ebeL105

Since then, config.processor_allowUpscaling is checked and it's reversed now.

Generally, it would make sense to switch to (e.g.) config.allowUpscaling, but we have to announce that as breakingchange-rst or by deprecating the old one config.noScaleUp AND of course, adding that information in the TYPO3 documentation!

My suggested solution

I would suggest to deprecate the old one and switch to a meaningful naming like config.allowUpscaling


Related issues

Related to TYPO3 Core - Task #43085: Rename setting im_version_5 to something more appropriate Closed 2012-11-18
Related to TYPO3 Core - Bug #78317: Deprecate config.noScaleUp Closed 2016-10-17

Associated revisions

Revision 87d35e37 (diff)
Added by Josef Glatz about 3 years ago

[BUGFIX] Make TypoScript option config.noScaleUp work again

A former commit introduced a bug, which makes `config.noScaleUp`
useless. This commit fixes the regression introduced in
https://review.typo3.org/#/c/42385/ by making the option work again.

Change-Id: Ia72a605bf6f2740ca66012f84cf2723e42eaabcb
Releases: master
Resolves: #78134
Reviewed-on: https://review.typo3.org/50236
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Josef Glatz about 3 years ago

  • Description updated (diff)

#2 Updated by Benni Mack about 3 years ago

Hey Josef,

I wonder if we should make the old property work again, but deprecate it, as I don't see a reason to have this configurable on a "per-TypoScript" condition / setting level. Either I do this per installation or I don't (well, I personally don't see the reason for this option at all, but globally it would be fine for me). What'ya think?

#3 Updated by Daniel Goerz about 3 years ago

  • Sprint Focus set to Stabilization Sprint

#4 Updated by Riccardo De Contardi about 3 years ago

Is this one related, maybe? https://forge.typo3.org/issues/72554

#5 Updated by Frans Saris about 3 years ago

No that issue isn't related

#6 Updated by Josef Glatz about 3 years ago

Sounds like a great idea, Benni!

In most project I've seen these setting is defacto a default setting. I'm fine with just configure that via global configuration.

#7 Updated by Josef Glatz about 3 years ago

  • Status changed from New to Accepted
  • Assignee set to Josef Glatz

#8 Updated by Gerrit Code Review about 3 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50236

#9 Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50236

#10 Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50236

#11 Updated by Gerrit Code Review about 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50236

#12 Updated by Gerrit Code Review about 3 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50236

#13 Updated by Gerrit Code Review about 3 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50236

#14 Updated by Anonymous about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#15 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF