Bug #79647

Add hooks to enable extension using the old typoLinkHandler syntax to migrate data

Added by Markus Klein almost 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2017-02-06
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

This is a followup to the new link-syntax introduced with version 8.
Extensions using the typoLinkHandler syntax '<identifier>:...' currently do not work anymore and have no sane possibility to migrate old links.

The Core code contains todo annotations with this issue number attached.

BUGFIX_Convert_legacy_parameters_in_record_link_handler.patch View (1.39 KB) Marc Bastian Heinrichs, 2018-04-11 16:08


Related issues

Related to TYPO3 Core - Bug #80806: Upgrade Wizard / Execute database migrations on single rows / Error: The RecordLinkHandler expects identifier and uid as $parameter configuration Closed 2017-04-11

Associated revisions

Revision 1f54e704 (diff)
Added by Daniel Goerz almost 2 years ago

[TASK] Add hook for resolving custom link types

The extendability of the link wizard is incomplete since the
refactoring of it. This patch adds a missing hook to resolve custom
link syntax in the LinkService. It is now possible (again) to
resolve links that start with <identifier>:

Resolves: #79647
Releases: master, 8.7
Change-Id: Iaf0c18f72aa799ab44a8bd14bddd0ca6c3530198
Reviewed-on: https://review.typo3.org/56730
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Tested-by: TYPO3com <>
Reviewed-by: Frans Saris <>
Reviewed-by: Riny van Tiggelen <>
Reviewed-by: Joerg Boesche <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

Revision f8b62af1 (diff)
Added by Daniel Goerz almost 2 years ago

[TASK] Add hook for resolving custom link types

The extendability of the link wizard is incomplete since the
refactoring of it. This patch adds a missing hook to resolve custom
link syntax in the LinkService. It is now possible (again) to
resolve links that start with <identifier>:

Resolves: #79647
Releases: master, 8.7
Change-Id: Iaf0c18f72aa799ab44a8bd14bddd0ca6c3530198
Reviewed-on: https://review.typo3.org/56790
Tested-by: TYPO3com <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

History

#1 Updated by Christian Kuhn almost 3 years ago

  • Target version deleted (8 LTS)
  • Sprint Focus deleted (Stabilization Sprint)

#2 Updated by Mathias Schreiber about 2 years ago

  • Is Regression changed from Yes to No

#3 Updated by Marc Bastian Heinrichs almost 2 years ago

  • Related to Bug #80806: Upgrade Wizard / Execute database migrations on single rows / Error: The RecordLinkHandler expects identifier and uid as $parameter configuration added

#4 Updated by Marc Bastian Heinrichs almost 2 years ago

Info: the todo annotation was deleted with https://review.typo3.org/#/c/52684/

#5 Updated by Marc Bastian Heinrichs almost 2 years ago

Since the LegacyLinkNotationConverter already provides the key url with all info needed based on the old linkhandler notation

list($a['identifier'], $a['table'], $a['uid']) = explode(':', $linkHandlerValue);
$result['url'] = $a;

I would like to see this handled in RecordLinkHandler instead of having a simple hook. See attached patch.

#6 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56730

#7 Updated by Daniel Goerz almost 2 years ago

I stumpled over this missing API today and had to XCLASS the LinkService. I pushed my proposal for an hook, although I am not entirely sure if I got this ticket right.

Here is an example extension that uses the newly introduced hook for testing and verifying purposes: https://github.com/ervaude/forge_links

#8 Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56730

#9 Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56730

#10 Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56730

#11 Updated by Gerrit Code Review almost 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56730

#12 Updated by Gerrit Code Review almost 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56730

#13 Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56790

#14 Updated by Daniel Goerz almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#15 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF