Bug #81250

Preview link of content element misses the anchor in some cases

Added by Dan Untenzu over 1 year ago. Updated about 1 year ago.

Status:
Under Review
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-05-18
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I open a preview of an content element, then the anchor is missing in some cases.

  • Module „List“ → Table “Table Content“ → Button “View webpage” → Opens popup with link to the current page and an anchor to the selected content element
  • Module »Page« or »List« → Context Menu on Icon of a content element → Selection »Show« → Opens popup with link to the current page and no anchor to the selected content element
  • Module »Page« or »List« → Edit a content element → Button »Save and view page« → Opens popup with link to the current page and no anchor to the selected content element

If the table is »tt_content«, then the anchor should either always be used or never.

Effects TYPO3 7, 8 and master.


Related issues

Related to TYPO3 Core - Bug #80598: Backend: Preview link for content elements in list module contains wrong anchor / missing c Closed 2017-03-31
Related to TYPO3 Core - Feature #81252: Make use of »TCEMAIN.preview« in all preview links New 2017-05-18
Related to TYPO3 Core - Bug #82456: Multiple usage of "save and preview" button does not reload preview tab Closed 2017-09-11

Associated revisions

Revision 4973abb6 (diff)
Added by Dan Untenzu over 1 year ago

[BUGFIX] Set anchor in all preview links of content elements

The button »View webpage« in the list module opens a popup
with a link to the current page and an anchor to the
selected content element. This behaviour is expected as well
while selecting the »Show« option in the context menu of
content elements or the »Save and view page« button in
edit forms. Both places didn't added the anchor.

Resolves: #81250
Releases: master, 8.7
Change-Id: Ifa8da940eb12820f9b0c54957928fd8d9f3703b5
Reviewed-on: https://review.typo3.org/53395
Tested-by: TYPO3com <>
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>
Reviewed-by: Henning Liebe <>
Tested-by: Henning Liebe <>
Reviewed-by: Joerg Boesche <>
Tested-by: Joerg Boesche <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

Revision 6a480e99 (diff)
Added by Dan Untenzu over 1 year ago

[BUGFIX] Set anchor in all preview links of content elements

The button »View webpage« in the list module opens a popup
with a link to the current page and an anchor to the
selected content element. This behaviour is expected as well
while selecting the »Show« option in the context menu of
content elements or the »Save and view page« button in
edit forms. Both places didn't added the anchor.

Resolves: #81250
Releases: master, 8.7
Change-Id: Ifa8da940eb12820f9b0c54957928fd8d9f3703b5
Reviewed-on: https://review.typo3.org/53691
Tested-by: TYPO3com <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

Revision 78f0bf0e (diff)
Added by Frank Naegler about 1 year ago

[BUGFIX] Fix broken reload of save+preview links

Resolves: #82456
Related: #81250
Releases: master
Change-Id: Idab208c3273adbd5800edab51bd9ca7bbec19af8
Reviewed-on: https://review.typo3.org/54218
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Jasmina Ließmann Reviewed-by: Mathias Schreiber <mathias.schreiber@typo3.com> Tested-by: Mathias Schreiber <mathias.schreiber@typo3.com> Reviewed-by: Helmut Hummel <typo3@helhum.io> Tested-by: Helmut Hummel <typo3@helhum.io>

History

#1 Updated by Dan Untenzu over 1 year ago

  • Related to Bug #80598: Backend: Preview link for content elements in list module contains wrong anchor / missing c added

#2 Updated by Dan Untenzu over 1 year ago

  • Related to Feature #81252: Make use of »TCEMAIN.preview« in all preview links added

#3 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52831

#4 Updated by Markus Klein over 1 year ago

  • Status changed from Under Review to New

#5 Updated by Dan Untenzu over 1 year ago

  • Description updated (diff)

#6 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53395

#7 Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53395

#8 Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53395

#9 Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53691

#10 Updated by Dan Untenzu over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Gerrit Code Review over 1 year ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53695

#12 Updated by Felix Nagel about 1 year ago

  • Related to Bug #82456: Multiple usage of "save and preview" button does not reload preview tab added

#13 Updated by Frank Naegler about 1 year ago

because this patch introduce a regression, the patch to this issue will be reverted for the v8 branch, for master we will merge a bugfix.

Also available in: Atom PDF