Bug #84008

Drag 'n drop of page in page tree does not work

Added by Sybille Peters over 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Category:
Pagetree
Target version:
-
Start date:
2018-02-22
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

I had this problem in the current master (9.2.0-dev).

If it isn't easily reproducable, let me know and I'll look into it further.

Steps to reproduce

  1. Create a new page with right mouse click, New
  2. Move the page by dragging till the place to insert changes to a line
  3. Dialog pops up, click on move

Expected result

Page is moved

Actual results

Page stays where it is

Schermata 2018-05-05 alle 22.38.14.png View (23.7 KB) Riccardo De Contardi, 2018-05-05 22:39

dragndrop2_clip.png View (27.6 KB) Sybille Peters, 2018-05-07 12:30

dragndrop1_clip.png View (26.4 KB) Sybille Peters, 2018-05-07 12:30

pagetree-new1.gif View (448 KB) Sybille Peters, 2018-08-03 14:49

Associated revisions

Revision 96e3bbe7 (diff)
Added by Paweł Rogowicz about 1 year ago

[BUGFIX] Move page correctly when droping page before another one

Fixes an issue where drag and dropping page before a another one didn't
detect the previous page correctly. DataHandler always expect
us to put a node AFTER. So when we want to place a page before, we need
to find previous page and put the new on after it.

Now it correctly compares depth of the node mouse is over with a previous
node. Before it took a dragged node depth for a comparison, which was wrong.

Releases: master
Resolves: #84008
Change-Id: Ic43be1147a5bb0fc1e15943a5d9e235d10727a07
Reviewed-on: https://review.typo3.org/57809
Tested-by: TYPO3com <>
Reviewed-by: Joerg Kummer <>
Tested-by: Joerg Kummer <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

History

#1 Updated by Wouter Wolters over 1 year ago

  • Category changed from Backend API to Pagetree

#2 Updated by Tymoteusz Motylewski over 1 year ago

can't reproduce it, can you PM me on slack?

#3 Updated by Sybille Peters over 1 year ago

  • current master: not reproducable
  • 9.1.0 : reproducable

Probably fixed or weird / hard to reproduce bug?

#4 Updated by Riccardo De Contardi over 1 year ago

It is still reproducible on 9.3.0-dev, I think ... but I can't understand under what conditions it is exactly reproducible; in general it fails when you try to move a page on a level below (see attached screenshot)

#5 Updated by Sybille Peters over 1 year ago

This is probably the same thing Riccardo described: I have noticed this several times (usually with latest 9 master).

Not reproducable: If I drag'n drop another page into 1 page (I mean while dragging I select the entire page)

Reproducable: If I drag and drop above / below a page (a thin line is shown). Then, the page does not get moved.

#6 Updated by Tymoteusz Motylewski about 1 year ago

  • Sprint Focus set to On Location Sprint

#7 Updated by Anja Leichsenring about 1 year ago

  • Status changed from New to Needs Feedback

I just tried my best to reproduce on a current master installation (running on fluid-styled-content), but I was not able to. Pages get moved and copied just fine, into and next to, from new pages and existing pages. Please verify the issue is solved?

#8 Updated by Sybille Peters about 1 year ago

I could not reproduce it either with existing pages.

But I could reproduce it, if I create a new page:

With introduction package:

1. Select start page "Congratulations"
2. Create another page : "another page"
3. Try to drag "another page" in between 2 existing pages

Result : page stays where it is.

  • Used latest master.
  • Tested again, using fresh installation (new database etc.), without additional extensions (no introduction and bootstrap_package): same results.

#9 Updated by Sybille Peters about 1 year ago

Additional information:

It's not always reproducible in the same way.

Try to play around, use various variants of "Move" or "Cancel", create new pages and move them around.

In the animated gif, you can see an example, where the behaviour is correct according to what is displayed in the dialog "to after start page", but it was tried to move the page between "page 1" and "page 2" and the thin line was visible.

#10 Updated by Paweł Rogowicz about 1 year ago

  • Assignee set to Paweł Rogowicz

#11 Updated by Tymoteusz Motylewski about 1 year ago

  • Status changed from Needs Feedback to Accepted

#12 Updated by Gerrit Code Review about 1 year ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57809

#13 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57809

#14 Updated by Paweł Rogowicz about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#15 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF