Bug #84146

"Reports" says update wizard incomplete

Added by Robert Wildling about 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Reports
Target version:
Start date:
2018-03-05
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The Reports tool says that the update wizard is incomplete and recommends to switch to the install tool and check the update wizard there.
But the install tool's update wizard shows 100%.

This happened after an update from 8.7.9 to 8.7.10, php 7.1.13 on at least 3 different installations.

Images included.

Screen Shot 2018-03-05 at 22.30.05.png View (69.7 KB) Robert Wildling, 2018-03-05 22:31

Screen Shot 2018-03-05 at 22.32.01.png View (34.6 KB) Robert Wildling, 2018-03-05 22:32


Related issues

Related to TYPO3 Core - Bug #86632: Reports complaining that "Update incomplete" Closed 2018-10-11

Associated revisions

Revision 8fa130ae (diff)
Added by Jigal van Hemert about 1 year ago

[BUGFIX] Check registry for upgrade wizard report

In the Reports module the check for unfinished upgrade wizards also
checks the registry to see if a wizard is marked as done. Upgrade
wizards can be marked as done even if their function
shouldRenderWizard() indicates that they are not finished. The
Reports module now shows the same status as the Install Tool.

Resolves: #84146
Releases: 8.7
Change-Id: I994f362545437743216cfc9a64fbf0d6af394379
Reviewed-on: https://review.typo3.org/56049
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Georg Ringer about 1 year ago

  • Status changed from New to Accepted
  • Target version changed from 9.2 to 8.7.11

#2 Updated by Jigal van Hemert about 1 year ago

  • Status changed from Accepted to Needs Feedback

Robert, it seems that at least one of the upgrade wizards in the context of the Reports modules finds that it hasn't finished the upgrade.
Can you modify \TYPO3\CMS\Install\Report\InstallStatusReport::getRemainingUpdatesStatus() to make $message show $identifier and $className?

It could be that more wizards think they are not finished. In that case the code could be:

if ($updateObject->shouldRenderWizard()) {
  // at least one wizard was found
  $value = $languageService->getLL('status_updateIncomplete');
  $severity = Status::WARNING;
  $url = BackendUtility::getModuleUrl('system_extinstall');
  $message .= $identifier . ':' . $className . ', ';
}

From there the affected wizards can be checked further.

#3 Updated by Robert Wildling about 1 year ago

Jigal - do your TYPO3 installations n ot show the same problem?

Message after implementing your script:

Update Incomplete
This installation is not configured for the TYPO3 version it is running. If you did so intentionally, this message can be safely ignored. If you are unsure, visit the Update Wizard section of the Install Tool to see how TYPO3 would change.
TYPO3\CMS\Install\Updates\DatabaseRowsUpdateWizard:TYPO3\CMS\Install\Updates\DatabaseRowsUpdateWizard,

#4 Updated by Jigal van Hemert about 1 year ago

Robert,

Finally I found an installation that shows this behaviour. It was in a different wizard. A patch will follow soon.

#5 Updated by Gerrit Code Review about 1 year ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56044

#6 Updated by Robert Wildling about 1 year ago

Thanks a lot, Jigal, for your quick fix!
Looking into it...

#7 Updated by Robert Wildling about 1 year ago

Thanks a lot, Jigal, for your quick fix!
The changed code works fine on my 8.7.10 installation. But the file itself (that is: your file) is a bit different in the import statement section (your file has less import statements than 8.7.10). Do I still vote +1?

A side note: There is a grammar error around line 62:
// 1 = required, don't has to be writable
should be:
// 1 = required, doesn't have to be writable

Can you take this fix along with this one or should I create a separate issue?

#8 Updated by Christian Kuhn about 1 year ago

Robert. Thanks for your testing! I may agree this fixes an issue for v8, but we're currently first discussing the patch for core master branch (v9). If that is sorted out, we later back port to v8. This is the reason the patch did not apply cleanly to v8 - a master variant has been pushed first. For master however, my testing says the v9 master core branch is not affected by the bug (maybe has been fixed meanwhile). If that turns out to be true and we can still reproduce the issue for v8, we may then decide to abandon the master patch and only fix it in v8 in a separate patch.

#9 Updated by Gerrit Code Review about 1 year ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56049

#10 Updated by Jigal van Hemert about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Benni Mack 8 months ago

  • Status changed from Resolved to Closed

#12 Updated by Alexander Stehlik 6 months ago

  • Related to Bug #86632: Reports complaining that "Update incomplete" added

Also available in: Atom PDF