Bug #86632

Reports complaining that "Update incomplete"

Added by Thomas Löffler about 2 months ago. Updated 1 day ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Reports
Target version:
-
Start date:
2018-10-11
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

I upgraded a TYPO3 8.7 page to 9.5 and set all wizards as done.
For every legacy extension it wanted to install I set "No, thanks".

On the Upgrade wizard setting the process bar is at 100% and it says, all wizards are done.
When I now go to Reports module, it complains, that the update is incomplete.

When debugging which class marks the update as incomplete it gives me:
\TYPO3\CMS\Install\Updates\Compatibility7ExtractionUpdate

When I look into the function updateNecessary() it only checks if the extension is loaded.
But if I don't want to install this extension, the update is always necessary?


Related issues

Related to TYPO3 Core - Bug #84146: "Reports" says update wizard incomplete Closed 2018-03-05
Duplicated by TYPO3 Core - Bug #86721: Reports module shows "Update Incomplete" but all wizards are done Closed 2018-10-23

Associated revisions

Revision 5a525d86 (diff)
Added by Susanne Moog about 2 months ago

[BUGFIX] Use consistent API for checking update status

Instead of re-implementing checking of update wizards in
the status report, the same methods for checking should be
used to generate the same status as the install tool upgrade
wizard section itself.

Resolves: #86632
Releases: master
Change-Id: Ifc0f282dcb42dd52b79e65c31e29f52b46e54593
Reviewed-on: https://review.typo3.org/58620
Reviewed-by: Mathias Brodala <>
Tested-by: Mathias Brodala <>
Tested-by: TYPO3com <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

Revision 3d5456e3 (diff)
Added by Alexander Stehlik 1 day ago

[BUGFIX] Ignore wizards with no upgrades in report

The reports module now ignores upgrade wizards that do
not have any necessary upgrades (shouldRenderWizard property
is false).

This makes the behavior fully consistent with the install tool
because there the wizards that should not be rendered are not
displayed either.

Resolves: #86632
Releases: master
Change-Id: I87caf45023a0ca4eca71418e029bc8ed7091c0e4
Reviewed-on: https://review.typo3.org/59048
Tested-by: TYPO3com <>
Reviewed-by: Wittkiel Gruppe <>
Reviewed-by: Stefan Neufeind <>
Reviewed-by: Joerg Kummer <>
Tested-by: Joerg Kummer <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Gerrit Code Review about 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58620

#2 Updated by Gerrit Code Review about 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58620

#3 Updated by Susanne Moog about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Georg Ringer about 2 months ago

  • Duplicated by Bug #86721: Reports module shows "Update Incomplete" but all wizards are done added

#5 Updated by Wittkiel Gruppe about 2 months ago

After applying this patch manually on TYPO3 9.5.0, we still have this problem. The process bar in upgrade wizards is at 100 %. In array $incompleteWizards are these wizards (we have no entries in sys_domain and no sys_language):

Array
(
    [0] => Array
        (
            [class] => TYPO3\CMS\Install\Updates\FileReferenceUpdate
            [identifier] => fileReferenceUpdate
            [title] => Migrate file references that are stored in a wrong way to correct scheme
            [shouldRenderWizard] =>
            [explanation] => File references were saved in a wrong way and references are not shown correctly in file list module.
        )

    [1] => Array
        (
            [class] => TYPO3\CMS\Install\Updates\LanguageSortingUpdate
            [identifier] => sysLanguageSorting
            [title] => Update sorting of sys_language records
            [shouldRenderWizard] =>
            [explanation] => The sys_language records have unsorted rows.  This upgrade wizard adds values depending on the language title
        )

    [2] => Array
        (
            [class] => TYPO3\CMS\Install\Updates\MigratePagesLanguageOverlayUpdate
            [identifier] => pagesLanguageOverlay
            [title] => Migrate content from pages_language_overlay to pages
            [shouldRenderWizard] =>
            [explanation] => The table pages_language_overlay will be removed to align the translation handling for pages with the rest of the core. This wizard transfers all data to the pages table by creating new entries and linking them to the l10n parent. This might take a while, because max. (amount of pages) x (active languages) new entries need be created.
        )

    [3] => Array
        (
            [class] => TYPO3\CMS\Install\Updates\RedirectsExtensionUpdate
            [identifier] => redirects
            [title] => Install system extension "redirects" if a sys_domain entry with redirectTo is necessary
            [shouldRenderWizard] =>
            [explanation] => The extension "redirects" includes functionality to handle any kind of redirects. The functionality superseds sys_domain entries with the only purpose of redirecting to a different domain or entry. This upgrade wizard installs the redirect extension if necessary and migrates the sys_domain entries to standard redirects.
        )

)

#6 Updated by Vasyl Mosiychuk 27 days ago

  • PHP Version set to 7.2

I did new install TYPO3 version 9.5.1 but I still have this problem.

#7 Updated by Alexander Stehlik 4 days ago

  • Related to Bug #84146: "Reports" says update wizard incomplete added

#8 Updated by Gerrit Code Review 4 days ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59048

#9 Updated by Alexander Stehlik 4 days ago

  • Category set to Reports
  • Complexity set to easy

The problem here was, that the reports module ignored the shouldRenderWizard property.

I pushed a patch that should solve this for good. Please test & review :)

#10 Updated by Alexander Stehlik 1 day ago

  • Status changed from Under Review to Resolved

Also available in: Atom PDF