Bug #84267

Unique evaluation does not work with l10n_mode=exclude

Added by Christoph Lehmann over 2 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Localization
Target version:
-
Start date:
2018-03-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Translation handling changed with l10n_mode=exclude, the field is copied from default language to language children. In combination with eval=unique the language children get a unique value too like “fieldvalue1”.

My expected behaviour is: uniqueness is ignored for translated records, since the values are just copied.


Related issues

Related to TYPO3 Core - Task #86780: Add test for (wrong) unique eval handling in pages:aliasClosedBenni Mack2018-10-28

Actions
Related to TYPO3 Core - Bug #90653: TCA eval with uniqueInPid: allow identical value in localized contentNeeds Feedback2020-03-05

Actions
Related to TYPO3 Core - Bug #87038: Unique evaluation does not work with l10n_mode=exclude after editing original record againClosedBenni Mack2018-11-29

Actions
Is duplicate of TYPO3 Core - Bug #83572: Changed behaviour for uniqueInPid/unique in translated recordsClosed2018-01-15

Actions
Has duplicate TYPO3 Core - Bug #84666: Page alias is changed for translated pagesClosed2018-04-08

Actions
#1

Updated by Christoph Lehmann over 2 years ago

I'm going to make a commit based on our quickfix

#2

Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56151

#3

Updated by Christoph Lehmann over 2 years ago

  • Assignee set to Oliver Hader

Example

An Attributegroup record is a collection of attributes, references them by a code (a comma-separated list) and is not translatable.
An attribute record is translatable and the code field has l10n_mode=exclude and eval=unique.

In Extbase the $wantedAttribute is not found in a foreign language since extbase only finds the attribute with code "fieldvalue1".

foreach ($attributeGroup->getCodes() as $attributeCode) {
    $wantedAttribute = $attributeRepository->findByCode($attributeCode); 
}

#4

Updated by Andreas Wolf over 2 years ago

  • Is duplicate of Bug #83572: Changed behaviour for uniqueInPid/unique in translated records added
#5

Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56151

#6

Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56151

#7

Updated by Gerrit Code Review over 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56151

#8

Updated by Gerrit Code Review over 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56151

#9

Updated by Susanne Moog over 2 years ago

  • Has duplicate Bug #84666: Page alias is changed for translated pages added
#10

Updated by Gerrit Code Review over 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56151

#11

Updated by Gerrit Code Review over 2 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56151

#12

Updated by Benni Mack about 2 years ago

  • Related to Task #86780: Add test for (wrong) unique eval handling in pages:alias added
#13

Updated by Gerrit Code Review about 2 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56151

#14

Updated by Christoph Lehmann about 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#15

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed
#16

Updated by Gerrit Code Review about 1 year ago

  • Status changed from Closed to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61792

#17

Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61792

#18

Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61792

#19

Updated by Gerrit Code Review about 1 year ago

Patch set 4 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61792

#20

Updated by Gerrit Code Review about 1 year ago

Patch set 5 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61792

#21

Updated by Christoph Lehmann about 1 year ago

  • Status changed from Under Review to Resolved
#22

Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed
#23

Updated by Georg Ringer 9 months ago

  • Related to Bug #90653: TCA eval with uniqueInPid: allow identical value in localized content added
#24

Updated by Christian Kuhn 3 months ago

  • Related to Bug #87038: Unique evaluation does not work with l10n_mode=exclude after editing original record again added

Also available in: Atom PDF