Bug #87153

Reset password in the `felogin` not working

Added by Vasyl Mosiychuk 9 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
felogin
Target version:
-
Start date:
2018-12-13
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
hard
Is Regression:
Yes
Sprint Focus:

Description

I am faced with problem reset password in the `felogin` (TYPO3 9.5.2 and PHP 7.2) (I tested).

Someone can confirm it?

In the TYPO3 9.5.1 - `felogin` reset password is good working (I tested)


Related issues

Related to TYPO3 Core - Task #83334: GeneralUtility::implodeArrayForUrl should always encode param-names Closed 2017-12-14
Related to TYPO3 Core - Bug #87664: fe_login password reset link is double encoded Closed 2019-02-06
Duplicated by TYPO3 Core - Bug #87286: felogin: Link in reset password mail is double-urlencoded Closed 2018-12-24
Duplicated by TYPO3 Core - Bug #87403: felogin: password forgotten form is not displayed after clicking link in email - double encoded forgothash Closed 2019-01-11

Associated revisions

Revision ad4f700d (diff)
Added by Gerrit Mohrmann 8 months ago

[BUGFIX] Remove rawurlencode from felogin reset password link

Link is encoded twice since #83334.
The patch removes the rawurlencode from FrontendLoginController

Resolves: #87153
Related: #83334
Releases: master, 9.5
Change-Id: I91a99e952300fb57cc1e9097738ab7f21ea6e9a4
Reviewed-on: https://review.typo3.org/59155
Tested-by: TYPO3com <>
Reviewed-by: Guido Schmechel <>
Reviewed-by: Oliver Klee <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Tested-by: Mona Muzaffar <>
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>

Revision cc3e6f1c (diff)
Added by Gerrit Mohrmann 8 months ago

[BUGFIX] Remove rawurlencode from felogin reset password link

Link is encoded twice since #83334.
The patch removes the rawurlencode from FrontendLoginController

Resolves: #87153
Related: #83334
Releases: master, 9.5
Change-Id: I91a99e952300fb57cc1e9097738ab7f21ea6e9a4
Reviewed-on: https://review.typo3.org/59407
Tested-by: TYPO3com <>
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>

History

#1 Updated by Vasyl Mosiychuk 9 months ago

I tested the Bug #87153 with TYPO 9.5.3 and PHP 7.2.6 - reset password in the `felogin` still not working

#2 Updated by Gerrit Mohrmann 9 months ago

  • Related to Task #83334: GeneralUtility::implodeArrayForUrl should always encode param-names added

#3 Updated by Gerrit Code Review 9 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59155

#4 Updated by Vasyl Mosiychuk 9 months ago

Yes, It is helped me and resolved my issue. Thanks!

#5 Updated by Mathias Brodala 9 months ago

  • Is Regression set to Yes

#6 Updated by Wouter Wolters 9 months ago

  • Duplicated by Bug #87286: felogin: Link in reset password mail is double-urlencoded added

#7 Updated by Georg Ringer 8 months ago

  • Duplicated by Bug #87403: felogin: password forgotten form is not displayed after clicking link in email - double encoded forgothash added

#8 Updated by Gerrit Code Review 8 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59407

#9 Updated by Gerrit Mohrmann 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Georg Ringer 7 months ago

  • Related to Bug #87664: fe_login password reset link is double encoded added

#11 Updated by Benni Mack 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF