Bug #87688

routeEnhancer has problem with additional parameter longer than 31 characters or number as parameter

Added by Michael Telgkamp over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2019-02-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Routing
Complexity:
Is Regression:
Sprint Focus:

Description

There is a problem with a page using a routeEnhancer of type Plugin.

  • Calling the URL with no additional parameters works fine (e.g. example.com/route/slug )
  • Calling with a parameter up to 31 characters length (e.g. example.com/route/slug?abc4567890123456789012345678901 ), everything works fine
  • Calling with a parameter longer than 31 characters (e.g. example.com/route/slug?abc45678901234567890123456789012 ) there is an Exeption: #1537633463 OutOfRangeException Hash not resolvable in typo3/sysext/core/Classes/Routing/Enhancer/VariableProcessor.php:71
  • Calling with a parameter only containing number (e.g. example.com/route/slug?0 ) there is an Exception: TypeError - Argument 1 passed to TYPO3\CMS\Core\Routing\Enhancer\VariableProcessor::resolveHash() must be of the type string, integer given in typo3/sysext/core/Classes/Routing/Enhancer/VariableProcessor.php:373.

Related issues

Related to TYPO3 Core - Bug #89802: EnhancerSiteRequestTest has superfluous call of var_dump()Closed2019-11-29

Actions
Related to TYPO3 Core - Bug #89647: Forms routing not working because of option 'deflatedParameters'Closed2019-11-12

Actions
#1

Updated by Michael Telgkamp over 2 years ago

  • Description updated (diff)
#2

Updated by Guido Schmechel over 2 years ago

  • Category set to Link Handling, Site Handling & Routing
#3

Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60236

#4

Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60236

#5

Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60236

#6

Updated by Gerrit Code Review over 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60236

#7

Updated by Gerrit Code Review over 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60236

#8

Updated by Gerrit Code Review over 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60236

#9

Updated by Michael Telgkamp almost 2 years ago

Additional information: The original usecase is a call with added parameters for tracking a campaign - and all calls to this failed because the additional parameter caused an exception being thrown because the length of the parameter name was longer than 31 characters...

#10

Updated by Oliver Hader almost 2 years ago

What do I need to do in order to reproduce this behavior? Please provide relevant route configuration and URLs used in order to trigger the problem.
I was not able to reproduce the misbehavior in TYPO3 v10 with the information from above...

#11

Updated by Michael Telgkamp almost 2 years ago

To trigger the exception the parameter needs to be not defined for TYPO3 and longer than 31 characters or numbers only.

#12

Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62385

#13

Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62385

#14

Updated by Gerrit Code Review almost 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62385

#15

Updated by Gerrit Code Review almost 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62385

#16

Updated by Gerrit Code Review almost 2 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62385

#17

Updated by Gerrit Code Review almost 2 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62385

#18

Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62411

#19

Updated by Oliver Hader almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#20

Updated by Andreas Fernandez almost 2 years ago

  • Related to Bug #89802: EnhancerSiteRequestTest has superfluous call of var_dump() added
#21

Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62411

#22

Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62411

#23

Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62411

#24

Updated by Oliver Hader almost 2 years ago

  • Status changed from Under Review to Resolved
#25

Updated by Benni Mack almost 2 years ago

  • Status changed from Resolved to Closed
#26

Updated by Oliver Hader almost 2 years ago

  • Related to Bug #89647: Forms routing not working because of option 'deflatedParameters' added

Also available in: Atom PDF