Bug #87729

MenuProcessor can't cache

Added by Christian Toffolo almost 2 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Performance
Target version:
-
Start date:
2019-02-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

It's impossible to cache menu generated using MenuProcessor.

MenuProcessor Configuration contains invalid Arguments: cache.

Processing HMENU is an intensive process especially with expAll=1.
Using MenuProcessor actually means that the menu is processed at each page call (if the page is not yet cached)

Also, since actually MenuProcessor hard-code ACT and CUR, it could be useful to implement a feature that automatically caches the menu without ACT and CUR and then it overrides the cached menu, setting ACT and CUR over the cached menu.
See: https://gist.github.com/julrich/d91c1ac1968418e6ae8290f2a2e90afb


Related issues

Related to TYPO3 Core - Bug #57953: Rendering time of HMENU is really bad, maybe bug?Needs Feedback2014-04-15

Actions
#1

Updated by Susanne Moog over 1 year ago

  • Category set to Performance
#2

Updated by Jarvis H over 1 year ago

  • Related to Bug #57953: Rendering time of HMENU is really bad, maybe bug? added
#3

Updated by Benni Mack 9 months ago

  • Status changed from New to Closed

Hey Christian,

this is not really related to MenuProcessor (see the related issue) but HMENU sucks big time. I heavily recommend using EXT:menus (https://github.com/b13/menus) which solves all issues regarding caching for TYPO3 v9+.

Also available in: Atom PDF