Bug #88171

Latest symfony/routing release breaks Core

Added by Andreas Fernandez 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-04-18
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
nightmare
Is Regression:
Sprint Focus:

Description

The latest release of symfony/routing introduced a fix regarding trailing slashes, which breaks our current code base.


Related issues

Related to TYPO3 Core - Bug #88199: Redirect endless Loop on root page Closed 2019-04-24
Duplicated by TYPO3 Core - Bug #88177: Upgrading symfony routing causes endless redirects Closed 2019-04-19
Duplicated by TYPO3 Core - Bug #88188: Empty slug in page translations causes page not found error 404 Closed 2019-04-23

Associated revisions

Revision 389bb407 (diff)
Added by Susanne Moog 4 months ago

[BUGFIX] Mark symfony/routing 4.2.7 as conflict

Symfony/routing 4.2.7 changed routing behaviour, breaking backwards
compatibility and our implementation. Reported at symfony:

https://github.com/symfony/symfony/pull/31107#issuecomment-484681404

Mark that version as conflict until the behaviour is fixed.

Composer commands:
- composer update --lock

Resolves: #88171
Releases: master, 9.5
Change-Id: I6f2651a605c6339222626d37c307c04b8f0eadf8
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60509
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Benni Mack <>
Reviewed-by: Oliver Klee <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Andreas Fernandez <>

Revision 247cd2a9 (diff)
Added by Susanne Moog 4 months ago

[BUGFIX] Mark symfony/routing 4.2.7 as conflict

Symfony/routing 4.2.7 changed routing behaviour, breaking backwards
compatibility and our implementation. Reported at symfony:

https://github.com/symfony/symfony/pull/31107#issuecomment-484681404

Mark that version as conflict until the behaviour is fixed.

Composer commands:
- composer update --lock

Resolves: #88171
Releases: master, 9.5
Change-Id: I6f2651a605c6339222626d37c307c04b8f0eadf8
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60517
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Gerrit Code Review 4 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60509

#2 Updated by Gerrit Code Review 4 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60509

#3 Updated by Gerrit Code Review 4 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60509

#4 Updated by Gerrit Code Review 4 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60509

#5 Updated by Gerrit Code Review 4 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60509

#6 Updated by Gerrit Code Review 4 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60509

#7 Updated by Gerrit Code Review 4 months ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60509

#8 Updated by Gerrit Code Review 4 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60517

#9 Updated by Anonymous 4 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Georg Ringer 4 months ago

  • Duplicated by Bug #88177: Upgrading symfony routing causes endless redirects added

#11 Updated by Christian Spoo 4 months ago

How about using \Symfony\Component\Routing\Matcher\RedirectableUrlMatcher instead of \Symfony\Component\Routing\Matcher\UrlMatcher, rather than downgrading symfony/routing? This will enable $supportsTrailingSlash inside the routing logic and thus allow the SiteMatcher to use site prefixes with trailing slashes.
At first glance this should fix the problem although I haven't thoroughly tested all cases.

#12 Updated by Susanne Moog 4 months ago

The issue is already fixed on symfony side and will probably be included in the next release: https://github.com/symfony/symfony/pull/31107#issuecomment-484681404

#13 Updated by Riccardo De Contardi 4 months ago

  • Related to Bug #88199: Redirect endless Loop on root page added

#14 Updated by Susanne Moog 4 months ago

  • Duplicated by Bug #88188: Empty slug in page translations causes page not found error 404 added

#15 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF