Project

General

Profile

Actions

Bug #88776

closed

RTE field in flexform is not detected as "dirty" when close element

Added by Anonymous almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2019-07-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Way to reproduce:

Setup a simple Textfield in Flexform in a custom cElement (havn't testet Plugin but I expact the same behaviour there)

   <settings.mytext>
                <TCEforms>
                    <label>My Text</label>
                    <config>
                        <type>text</type>
                        <cols>48</cols>
                        <rows>15</rows>
                    </config>
                </TCEforms>
            </settings.mytext>

Crete an Element of you type, save it. Now change text in the mytext field and just close the element. TYPO3 detects your changes and ask you to save or discard your changes (we all know this behaviour :-) )

Now add RTE to the field:

   <settings.mytext>
                <TCEforms>
                    <label>My Text</label>
                    <config>
                        <type>text</type>
                        <cols>48</cols>
                        <rows>15</rows>
                        <enableRichtext>1</enableRichtext>
                    </config>
                </TCEforms>
            </settings.mytext>

Do the same as above. The element just gets closed without any dialog and all changes are lost.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #88875: Modal Page altered not shown everytimeClosed2019-08-01

Actions
Related to TYPO3 Core - Bug #88978: Close CE "Text & Media" after maximize and change won't saveClosed2019-08-20

Actions
Actions

Also available in: Atom PDF