Bug #88823

Re-introduce option to disable "Localization view" in list module and/or auto-disable it if only one language is configured

Added by Georg Tiefenbrunn over 2 years ago. Updated 27 days ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Backend User Interface
Start date:
2019-07-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Since #82991 "Localization view" is always used in list module.

When working with localizations in a system, the option "Localization view" in the list module is a pre-requisite for all editors, for all installations without languages, the checkbox is not necessary.

To streamline this behaviour, the option is removed and the functionality is enabled BY DEFAULT.

If there's only one language defined, the fields "[Localization]" and "Localize to" waste precious space and should be removed.


Related issues

Related to TYPO3 Core - Task #82991: Remove List module checkbox "Localization view"ClosedBenni Mack2017-11-14

Actions
Related to TYPO3 Core - Story #82206: list module enhancements/bugfixesNew2005-07-21

Actions
Related to TYPO3 Core - Bug #87901: Regression in TYPO3 v9: Mass-edit of localized records in List viewClosed2019-03-13

Actions
Related to TYPO3 Core - Task #94794: Hide "Localize to" column if all records are already localizedClosed2021-08-10

Actions
#1

Updated by Georg Tiefenbrunn over 2 years ago

  • Related to Task #82991: Remove List module checkbox "Localization view" added
#2

Updated by Daniel Windloff over 2 years ago

  • Related to Story #82206: list module enhancements/bugfixes added
#3

Updated by Georg Ringer over 2 years ago

  • Status changed from New to Accepted
  • Assignee set to Georg Ringer
#4

Updated by Gerrit Code Review over 2 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61372

#5

Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61372

#6

Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61372

#7

Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61372

#8

Updated by Gerrit Code Review almost 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61372

#9

Updated by Gerrit Code Review over 1 year ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61372

#10

Updated by Gerrit Code Review over 1 year ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61372

#11

Updated by Gerrit Code Review over 1 year ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61372

#12

Updated by Gerrit Code Review over 1 year ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61372

#13

Updated by Christian Toffolo about 1 year ago

  • Priority changed from Should have to Must have

This is indeed a must have. As a constructive criticism, I suggest core developers to test with some editors on a complex multi-language website before removing useful features like this one.

Actually I'm on the List module, trying to sort 48 categories with 4 languages, it's nearly impossible.

#14

Updated by Sybille Peters about 1 year ago

  • Related to Bug #87901: Regression in TYPO3 v9: Mass-edit of localized records in List view added
#15

Updated by Sybille Peters about 1 year ago

  • Tracker changed from Feature to Bug
  • TYPO3 Version set to 9
  • Is Regression set to Yes
#16

Updated by Christian Toffolo 5 months ago

  • Target version set to Candidate for Major Version
  • TYPO3 Version changed from 9 to 10

I changed this to TYPO3 10 and candidate for major version hoping to give it more attention.

Removing the option "Localization view" did lowered a lot the usability of the backend when there are many records and many languages.
In my use case they aren't even so many (just ~50 records with 4 languages) and it's already nearly impossible to manage the list.

As a side note: when I use TYPO3 as an editor I find many annoyances which I'm sure the developers don't realize because they don't use the backend enough as editors with complex websites (many images, many pages, many records and languages and so on) and I think that this issue should be handled seriously in some way because the experience of the editors is very important for the success of a CMS.

#17

Updated by Sybille Peters 5 months ago

@Christian

because the experience of the editors is very important for the success of a CMS.

see also Theme-based roadmap with 3 major goals, one subgoal of which is "Improved Editor Experience"

Make TYPO3 Easier to get started with and use
-> Improved Editor Experience

This is a little off-topic - but I also find editor UX very important. And I think this should be looked as a whole and not just as individual issues.

I don't know if the issues are priorititzed in any and what might contribute to an issue or topic getting bumped up in priority or importance.

Also what might be helpful if there were an iniative or a component merger for backend / editor UI or backend / editor UX - which there is currently not - not any component merger for backend UI / UX or editor experience at all, see Component Mergers or Initiatives

Maybe someone has a better idea of how to move forward with this general topic or get it on someone's radar.

P.S. If you find something lacking, see if there is anything you can do to help. There are some positive examples of initiatives where the topic was important to an individual or a group and they just started and worked on it and it evolved into an initiative.

#18

Updated by Sybille Peters 5 months ago

@christian

Another thought. Because you wrote:

when I use TYPO3 as an editor I find many annoyances which I'm sure the developers don't realize because they don't use the backend enough as editors with complex websites

same thing here. I work at a university with a large university website. I don't work as editor normally, but I sometimes have to reproduce problems or find solutions when editors report problems.

I have thought about conducting survey or doing something like usability tests with our editors for the TYPO3 backend (and of course also our custom adjustments). However, I have very little experience with this. But if someone would like to exchange knowhow and brainstorm a little with me, please contact me on Slack.

#19

Updated by Benni Mack 27 days ago

  • Related to Task #94794: Hide "Localize to" column if all records are already localized added
#20

Updated by Benni Mack 27 days ago

  • Status changed from Under Review to Closed

Version 11 now does not show the "Localize to" feature anymore if there is only one language. We also want to improve this in v12 ("Show me records only in DE, DK and FR" in list module and page module), but I will open up another ticket for this.

Also available in: Atom PDF