Bug #88918

Create page via drag'n'drop does not respect TCAdefaults in pagets [from #25021]

Added by Lukas Speck almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2019-08-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
pagetree, tcadefaults
Complexity:
Is Regression:
Sprint Focus:

Description

When creating a new page via drag'n'drop in the new pagetree the configured TCAdefaults settings from pagets won't be applied to the newly created page. This bug still exists in TYPO3 v9.


Related issues

Related to TYPO3 Core - Bug #89211: TCAdefaults.pages.hidden = 0 not working in TYPO3 9.5.9 and 10.1.0-dev using page tree drag & dropClosed2019-09-19

Actions
Related to TYPO3 Core - Bug #89685: TCAdefaults.pages.backend_layout not working for pages created via drag and dropClosed2019-11-14

Actions
Copied from TYPO3 Core - Bug #25021: Create page via drag'n'drop does not respect TCAdefaults in pagetsClosed2011-02-13

Actions
#1

Updated by Lukas Speck almost 3 years ago

  • Copied from Bug #25021: Create page via drag'n'drop does not respect TCAdefaults in pagets added
#2

Updated by Lukas Speck almost 3 years ago

  • Category set to Pagetree
#3

Updated by Oliver Bartsch almost 3 years ago

  • Status changed from New to Needs Feedback

Which fields did you set?

I'm not able to reproduce this neither in v9 nor in current master.

I used this configuration:

TCAdefaults.pages {
    is_siteroot = 1
}

#4

Updated by Georg Tiefenbrunn almost 3 years ago

TYPO3 9.5.x

# Page structure
+ Root [uid=1]
  + Sub [uid=2]

TCAdefaults via pages.TSconfig on page.uid=1

# Page TS
TCAdefaults.pages {
  is_siteroot = 1
  no_search = 1
  no_sitemap = 1
  no_index = 1
  no_follow = 1
}
  • Does work if a new page is inserted via list module > page.uid=2 > "new record"
  • Does not work when dragging a new page into uid=1|2

TCAdefaults via Pages.tsconfig and condition

# Page TS added by ExtensionManagementUtility::addPageTSConfig()
[page["uid"] == 901]
  TCAdefaults.pages {
    is_siteroot = 1
    no_search = 1
    no_sitemap = 1
    no_index = 1
    no_follow = 1
  }
[END]
  • Does work if a new page is inserted via list module > page.uid=2 > "new record" > direct child of page.uid=1
  • Does not work when the new page is no direct child of page.uid=1 (if e.g. is child of page.uid=2)
  • Does not work when dragging a new page into uid=1|2
#5

Updated by Eric Chavaillaz almost 3 years ago

I can confirm this bug, I just set the no_search value to 1.

Thanks

#6

Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from Needs Feedback to New
#7

Updated by Simon Gilli almost 3 years ago

  • Related to Bug #89211: TCAdefaults.pages.hidden = 0 not working in TYPO3 9.5.9 and 10.1.0-dev using page tree drag & drop added
#8

Updated by Ben Robinson over 2 years ago

  • Related to Bug #89685: TCAdefaults.pages.backend_layout not working for pages created via drag and drop added
#9

Updated by Susanne Moog over 2 years ago

  • Status changed from New to Closed

This has the same cause (and solution) as #89211 - closing as duplicate, please continue there.

Also available in: Atom PDF