Project

General

Profile

Actions

Bug #89307

closed

Epic #90674: Backend UI not reflecting permissions

List Module shows edit action icon even if User has no edit permission

Added by Anonymous over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-09-30
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The List Module shows all edit icons like:
- new Record
- edit
- delete
- hide

even when the editor does not have write permissions on that table. If the editot clicks on an Icon there is no Message (except delete) - just an inifnite frame-load.

Best would be to hide or disable the action buttons the editor is not allowed to, but at least there should be an error message saying that there are missing permissions to do that action.


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #89261: Editors can see free mode records (l18n_parent = 0) in list module which they don't have access toClosedChristian Eßl2019-09-25

Actions
Related to TYPO3 Core - Bug #40819: Edit icons (pencils) still visible in WS even though use has no modify accessClosed2012-09-11

Actions
Related to TYPO3 Core - Bug #83008: Edit Icon shown in list view despite user not having write permission for tableClosed2017-11-15

Actions
Actions #1

Updated by Christian Eßl over 4 years ago

Are the records by chance in free mode? Then it could be related to:
https://forge.typo3.org/issues/89261

Actions #2

Updated by Georg Ringer over 4 years ago

  • Related to Bug #89261: Editors can see free mode records (l18n_parent = 0) in list module which they don't have access to added
Actions #3

Updated by Georg Ringer over 4 years ago

  • Tracker changed from Feature to Bug
  • Status changed from New to Accepted
  • TYPO3 Version set to 9
Actions #4

Updated by Anonymous over 4 years ago

Seems to be the case - or the other problem has been solved meanwhile.

Actions #5

Updated by Riccardo De Contardi over 4 years ago

  • Parent task set to #90674
Actions #6

Updated by Riccardo De Contardi over 4 years ago

  • Related to Bug #40819: Edit icons (pencils) still visible in WS even though use has no modify access added
Actions #7

Updated by Riccardo De Contardi over 4 years ago

Is this a duplicate of #83008 ?

Actions #8

Updated by Riccardo De Contardi over 4 years ago

  • Related to Bug #83008: Edit Icon shown in list view despite user not having write permission for table added
Actions #9

Updated by Gerrit Code Review over 4 years ago

  • Status changed from Accepted to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63696

Actions #10

Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63696

Actions #11

Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63696

Actions #12

Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63696

Actions #13

Updated by Gerrit Code Review about 4 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63750

Actions #14

Updated by Gerrit Code Review about 4 years ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63750

Actions #15

Updated by Christian Eßl about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #16

Updated by Benni Mack about 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF