Bug #90679

"Restore record" does not restore record

Added by Andreas Fernandez almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2020-03-08
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If a page gets deleted in a workspace, it still may get recovered by the "Restore record" action in the Record List. However, when the confirmation is approved, anything else happens and the page seems to be gone completely.


Related issues

Related to TYPO3 Core - Bug #21299: Can't restore a deleted page in draft workspaceClosedOliver Hader2009-10-19

Actions
Related to TYPO3 Core - Bug #89383: Restoring deleted content element in workspace failsClosed2019-10-09

Actions
Related to TYPO3 Core - Bug #52700: Change delete icon in context menu if record is deletedClosed2013-10-062013-10-06

Actions
#1

Updated by Georg Ringer almost 2 years ago

  • Category set to Workspaces
#2

Updated by Riccardo De Contardi almost 2 years ago

Is this a duplicate of #21299 or #89383 ?

#3

Updated by Christian Kuhn over 1 year ago

  • Related to Bug #21299: Can't restore a deleted page in draft workspace added
#4

Updated by Christian Kuhn over 1 year ago

  • Related to Bug #89383: Restoring deleted content element in workspace fails added
#5

Updated by Christian Kuhn over 1 year ago

  • Related to Bug #52700: Change delete icon in context menu if record is deleted added
#6

Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65495

#7

Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65495

#8

Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65495

#9

Updated by Gerrit Code Review over 1 year ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65495

#10

Updated by Christian Kuhn over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#11

Updated by Gerrit Code Review over 1 year ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65498

#12

Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65498

#13

Updated by Christian Kuhn over 1 year ago

  • Status changed from Under Review to Resolved
#14

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF