Bug #91885

Page-Tree filter does not reset

Added by Ingo Fabbri about 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2020-07-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

You enter a filter-term in the page-tree filter input. you hit the explicit enter (yikes).

The page tree is filtered now (no info about the active filter - but thats another issue)

Now clear the whole filter-term from the filter-input-field. Just remove it with backspace, DEL or whatever you like to clear input-fields. until the field is empty (no chars left) and the placeholder shows again.

Expected result:

Applied filter is removed

Actual result:

Filter still active

TYPO3 10.4.6


Files

Untitled.png (3.95 KB) Untitled.png Ingo Fabbri, 2020-07-29 14:29

Related issues

Related to TYPO3 Core - Epic #88474: Page tree performance in 9.5Closed2018-11-16

Actions
Related to TYPO3 Core - Bug #91884: Page tree filter has no delete "X", needs hitting enter and has no filter info box anymore, a big backwards step regarding usabilityClosed2020-07-29

Actions
Related to TYPO3 Core - Bug #91891: Page tree should auto filterRejectedAndreas Fernandez2020-07-29

Actions
Related to TYPO3 Core - Bug #88943: Pagetree taking extremely long to load for editorsClosed2019-08-09

Actions
Related to TYPO3 Core - Bug #88098: Page tree XHR is fetching huge JSON dataClosed2019-04-06

Actions
Related to TYPO3 Core - Bug #88259: Filtered pagetree should display child pagesClosed2019-05-03

Actions
#1

Updated by Ingo Fabbri about 1 year ago

  • Related to Epic #88474: Page tree performance in 9.5 added
#2

Updated by Ingo Fabbri about 1 year ago

  • Related to Bug #91884: Page tree filter has no delete "X", needs hitting enter and has no filter info box anymore, a big backwards step regarding usability added
#3

Updated by Kai Strecker about 1 year ago

The cause for this bug is this line:
https://github.com/TYPO3/TYPO3.CMS/blob/v10.4.6/typo3/sysext/backend/Resources/Public/JavaScript/PageTree/PageTreeToolbar.js#L174

jQuery.fn.get returns a dom element, not a jQuery object.

To fix the bug, the line has to be changed from

let input = $submenu.find('input').get(0);

to
let input = $submenu.find('input').first();

#4

Updated by Andreas Fernandez about 1 year ago

  • Status changed from New to Needs Feedback

I fail to reproduce the issue. Which browser do you use? Or is this related to the "I have to press Enter" issue?

#5

Updated by Ingo Fabbri about 1 year ago

Andreas Fernandez wrote:

I fail to reproduce the issue. Which browser do you use? Or is this related to the "I have to press Enter" issue?

Version 84.0.4147.89

https://www.whatsmybrowser.org/b/J4PON

#6

Updated by Ingo Fabbri about 1 year ago

Ingo Fabbri wrote:

Andreas Fernandez wrote:

I fail to reproduce the issue. Which browser do you use? Or is this related to the "I have to press Enter" issue?

Version 84.0.4147.89

https://www.whatsmybrowser.org/b/J4PON

Same in Firefox.

#7

Updated by Ingo Fabbri about 1 year ago

Ingo Fabbri wrote:

Andreas Fernandez wrote:

I fail to reproduce the issue. Which browser do you use? Or is this related to the "I have to press Enter" issue?

Version 84.0.4147.89

https://www.whatsmybrowser.org/b/J4PON

Just don't hit enter. Remove the characters to empty the field.

until it looks like in the attachment

I think you can't expect people to hit enter on an empty field, just to make it do a reset.

#8

Updated by Andreas Fernandez about 1 year ago

So this is related to the issue I already created a patch for. Thanks, so I can link the issues.

#9

Updated by Andreas Fernandez about 1 year ago

  • Related to Bug #91891: Page tree should auto filter added
#10

Updated by Gerrit Code Review about 1 year ago

  • Status changed from Needs Feedback to Under Review

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65138

#11

Updated by Gerrit Code Review about 1 year ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65140

#12

Updated by Andreas Fernandez about 1 year ago

  • Category set to Pagetree
#13

Updated by Anja Leichsenring about 1 year ago

  • Related to Bug #88943: Pagetree taking extremely long to load for editors added
#14

Updated by Anja Leichsenring about 1 year ago

  • Related to Bug #88098: Page tree XHR is fetching huge JSON data added
#15

Updated by Anja Leichsenring about 1 year ago

  • Related to Bug #88259: Filtered pagetree should display child pages added
#16

Updated by Andreas Fernandez about 1 year ago

  • Status changed from Under Review to Rejected

The page tree patch has been reverted and gets revised now: https://review.typo3.org/c/Packages/TYPO3.CMS/+/65208

Also available in: Atom PDF