Bug #92748

Infinite redirects (redirect loop) when updating slugs

Added by Michal Cygankiewicz 11 months ago. Updated 6 months ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2020-11-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
redirects, redirect loop
Complexity:
Is Regression:
Sprint Focus:

Description

When backend user change slug of a page then there are sys_redirects that are created automatically. Following scenario will lead to whole part of page tree be inaccessible for visitors:

1. Page is called "Subpage" (slug: /subpage)
2. Page is beeing renamed to "Subpage something" and slug get's updated to "/subpage-something" at the same time redirect 307 is created (/subpage -> /subpage-something)
3. Page is beeing renamed to "Subpage" and slug get's updated to "/subpage" at the same time redirect 307 is created (/subpage-something -> /subpage)

After step 3 is done - infinite redirect has been created so subpage and all it's child pages are inaccessible at all due to infinite redirect.

We already had such a case with our redactors several times. Did anyone experienced similar problems and how you deal with that? Of course automatic redirects creation might be switched off by configuration but after all it's nice functionality - but could be quite dangerous at current state.


Related issues

Related to TYPO3 Core - Feature #93288: Merge redirect chainsNew2021-01-14

Actions
Related to TYPO3 Core - Bug #89090: No redirect loop prevention for slugs / redirectsClosed2019-09-05

Actions
Related to TYPO3 Core - Bug #89327: Auto redirect: Could not resolve target pageUnder ReviewFrank Naegler2019-10-01

Actions
#1

Updated by Riccardo De Contardi 10 months ago

  • Category set to Link Handling, Site Handling & Routing
#2

Updated by David Bruchmann 8 months ago

#3

Updated by Sybille Peters 8 months ago

I already reported this a while ago: #89090. The issue has been closed as resolved, see https://review.typo3.org/c/Packages/TYPO3.CMS/+/61627

Was added in 10.1, see changelog: https://docs.typo3.org/c/typo3/cms-core/master/en-us/Changelog/10.1/Feature-89090-ReportsForConflictingRedirects.html

The patch does not really resolve the issue - meaning it does not prevent redirect loops. However it does provide some tools:

What you can do is use the commands redirect:checkintegrity and / or redirects:cleanup regularly to check theredirects and cleanup old redirects periodically (e.g. using the hit count or age of the redirect):

run:
typo3/sysext/core/bin/typo3

(I have not tested this yet).

#4

Updated by Sybille Peters 8 months ago

  • Subject changed from Infinite redirects when updating slugs to Infinite redirects (redirect loop) when updating slugs
  • Tags set to redirects, redirect loop
#5

Updated by Sybille Peters 8 months ago

  • Related to Bug #89090: No redirect loop prevention for slugs / redirects added
#6

Updated by Wolfgang Klinger 8 months ago

Use extension
https://extensions.typo3.org/extension/sluggi/
to save your hair from turning grey with the slug handling of TYPO3 core :)

#7

Updated by Sybille Peters 6 months ago

Wolfgang Podbregar Klinger After only about a week after updating to v10, redirect chaos has already rendered a page unavailable (redirect loops). This had to be manually resolved by an admin by removing unncessary redirects. It happened because URLs of pages including subpages were changed several times.

I had already anticipated problems with the automatic renaming of URLs (on subpages) and automatic redirect creation. I am afraid it is a real challenge to prevent editors from pointless multiple changes of URLs (which may be well intended but create problems). Will checkout sluggi extension.

I am not really happy with this. Wanted to stick to core solution.

#8

Updated by Sybille Peters 5 months ago

  • Related to Bug #89327: Auto redirect: Could not resolve target page added

Also available in: Atom PDF