Bug #94077

PathUtility.php PHP Warning: is_file(): open_basedir restriction in effect

Added by Wittkiel Gruppe 7 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since #93048 there is a new condition in /core/Classes/Utility/PathUtility.php line 54:

elseif (file_exists(Environment::getPublicPath() . '/' . $targetPath))

This check triggers a warning like:

Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1476107295: PHP Warning: file_exists(): open_basedir restriction in effect. File(/var/www/example.com/web/../typo3conf/ext/dce/Resources/Public/JavaScript/Contrib/codemirror/lib/codemirror.css?1620224059) is not within the allowed path[...]

Easy fix would be to suppress warning with "@file_exists" like in other parts.

Non-composer
TYPO3: 11.2
PHP: 7.4


Related issues

Related to TYPO3 Core - Feature #93048: Introduce URL rewrites for Backend linksClosedOliver Bartsch2020-12-10

Actions
#1

Updated by Georg Ringer 7 months ago

  • Related to Feature #93048: Introduce URL rewrites for Backend links added
#2

Updated by Wittkiel Gruppe 3 months ago

  • Target version set to 11 LTS
#3

Updated by Wittkiel Gruppe 2 months ago

Since #95437 the culprit line is gone. Issue can be closed.

#4

Updated by Benni Mack 2 months ago

  • Target version changed from 11 LTS to Candidate for patchlevel
#5

Updated by Riccardo De Contardi about 2 months ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for patchlevel)

Solved with #95437

If you think that this is the wrong decision, please reopen it or ping me and I'll do.

Thank you.

Also available in: Atom PDF