Project

General

Profile

Actions

Bug #96907

closed

Undefined array key "uid" - /symfony/expression-language/Node/GetAttrNode.php line 97

Added by Rene Tobias over 2 years ago. Updated 25 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2022-02-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
8.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello,

every time i click somewhere in TYPO3 backend i get this error writen in Log:

Core: Error handler (BE): PHP Warning: Undefined array key "uid" in /var/www/vhosts/typo3_source/typo3_src-11.5.6/vendor/symfony/expression-language/Node/GetAttrNode.php line 97

I am using PHP 8.1.2 and TYPO3 11.5.6. The same problem is with 11.5.5

Can anyone help?


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #94707: Undefined array key / Trying to access array offset on value of type null / PHP Version 8.0.8Closed2021-08-04

Actions
Related to TYPO3 Core - Bug #101447: PHP Warning: Undefined array key "uid" in GetAttrNode.phpClosed2023-07-26

Actions
Is duplicate of TYPO3 Core - Bug #95781: PHP Warning: Undefined array key "uid" in /app/vendor/symfony/expression-language/Node/GetAttrNode.phpRejected2021-10-26

Actions
Actions #1

Updated by Patrick Crausaz over 2 years ago

Experiencing the same issue with TYPO3 11.5.6 and PHP 8.0.
The warning shows up in the backend Page module for every symfony expressions in TypoScript AND in tsconfig.

[page["uid"] == 123]
  ...
[end]

For my dev env, I did set SYS/exceptionalErrors to 28674 to ignore the warnings.

Actions #2

Updated by Georg Ringer over 2 years ago

  • Status changed from New to Needs Feedback

could not reproduce on 11 or 12.

are you using composer, if yes, which version of expression-language are you using? Please run
composer show | grep expression

works fine here with v5.4.0

Actions #3

Updated by Rene Tobias over 2 years ago

Hey, i am using "regular" TYPO3 installation, so no composer.

Actions #4

Updated by David Hoeckele over 2 years ago

  • Is duplicate of Bug #95781: PHP Warning: Undefined array key "uid" in /app/vendor/symfony/expression-language/Node/GetAttrNode.php added
Actions #5

Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Needs Feedback to Closed

I close this issue in favor of #95781

please continue the discussion there.

If you think that this is the wrong decision, please reopen it or ping me and I'll do. Thank you

Actions #6

Updated by Felix Nagel over 1 year ago

  • Related to Bug #94707: Undefined array key / Trying to access array offset on value of type null / PHP Version 8.0.8 added
Actions #7

Updated by Oliver Hader 12 months ago

  • Related to Bug #101447: PHP Warning: Undefined array key "uid" in GetAttrNode.php added
Actions #8

Updated by Markus Dübbert 25 days ago

[traverse(page, "uid") == 17]

solved the problem

Actions

Also available in: Atom PDF