Project

General

Profile

Actions

Bug #100694

closed

Spontaneous BE logout with safari

Added by Wolfgang Wagner about 1 year ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2023-04-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
12
PHP Version:
8.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the current Safari under MacOS Ventura 13.3.1 I am irregularly logged out of the backend of TYPO3 12.4.0-dev. The behavior is hardly reproducible. Error occurred when editing content elements, calling the page module and other actions.

The error could be reproduced by two other TYPO3 users.

Setup:
Local installation with Docker and DDEV
(In Safari the installation can only be reached via IP and port, in Chrome and Firefox everything works normally, but I think, this is only a local problem.)


Files

ErrorReportCrashingSafari.txt (39.1 KB) ErrorReportCrashingSafari.txt Stefan Froemken, 2023-04-20 18:36

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #102185: Can't login to typo3 backend on safari Closed2023-10-17

Actions
Actions #1

Updated by Stefan Froemken about 1 year ago

I can confirm this problem. I have added the Error Log of the MAC OS.

Actions #2

Updated by Stefan Froemken about 1 year ago

I now have searched over 4 hours to find a hint, to find a switch you can use to repair that issue. Sorry, I'm out now.

Nothing works:

  • Cookie: strict -> lax
  • Safari: Website Settings: Deactivate Content Blocker
  • Disable IPv6 on Mac
  • Safari: Deactivate all Safari Extensions
  • Safari: Disable IP Tracking
  • Safari: Disable overall website tracking
  • Safari: Deactivate privacy tracking for advertising
  • Safari: Clear all caches
  • Update to most current version of Ventura, Safari and XCode
  • Network: Switch from RJ45 to W-LAN
  • Renew DHCP Lease
  • Unset BE:HTTP
  • Activate BE:lockSSL
  • Switch from Debug to Production mode
  • Problem is the same with PHP 8.1 and PHP 8.2
  • It can't be a problem wit DDEV, as customer has the same problem with a server from Mittwald
  • I can't find any problem with the SSL certificate

Next topic: Try to analyze the error log of my Mac

  • It has something to do with the launchd service
  • The problem is somewhere in the WebKit component
  • EXC_BAD_ACCESS (SIGSEGV): Is an indication, that a service tries to access a RAM area which it is not allowed to.
  • Code 0x0000000000000042 is different from 0x1c6a2628c which confirms the violation
  • Last process which throws the exception has Code 0x1c6a2628c. This code is between 0x1c59e7000 - 0x1c70eefff which relates to: com.apple.JavaScriptCore (18615) <296c4d4b-246e-38db-99c4-b3de1a1352de> /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore
  • The Exception was thrown in this method: JSC::AbstractModuleRecord::resolveExportImpl(JSC::JSGlobalObject*, JSC::AbstractModuleRecord::ResolveQueryconst&)
  • In a special launchd.log protocol I found following warning lines:
    denied lookup: name = com.apple.backupd.sandbox.xpc, flags = 0x8, requestor = parsec-fbf[1482], error = 159: Sandbox restriction
    denied lookup: name = com.apple.biome.compute.source.user, requestor = contextstored[370], error = 159: Sandbox restriction
    denied lookup: name = com.apple.audio.AudioComponentRegistrar, requestor = com.apple.WebKi[16956], error = 159: Sandbox restriction
    denied lookup: name = com.apple.CoreServices.coreservicesd, flags = 0x9, requestor = com.apple.WebKi[16956], error = 159: Sandbox restriction
    denied lookup: name = com.apple.audio.SandboxHelper, requestor = com.apple.WebKi[16956], error = 159: Sandbox restriction
    denied lookup: name = com.apple.DiskArbitration.diskarbitrationd, flags = 0x9, requestor = com.apple.WebKi[16956], error = 159: Sandbox restriction
    
  • I have tried to deactivate the sandbox for safari. No chance.
  • I haven't found any further details in /var/log/system
  • There should be an additional sandboxd protocol, if you open Console.app with sudo. But I can't find it.
Actions #3

Updated by Stefan Froemken about 1 year ago

I just found this page: https://www.reddit.com/r/Safari/comments/yk2727/constantly_being_logged_out_of_sites/

After deactivating dev mode in safari it seems to work. For now I can navigate through TYPO3 BE for over 5 minutes now without logout. Wow.

Actions #4

Updated by Stefan Froemken about 1 year ago

  • Status changed from Accepted to Needs Feedback

After activating dev menu in safari again, I can not reproduce the error. Seems, something has been resetted.

Wolfgang: Can you please try open "Developer" -> "Experimental Features" -> "Reset to default" at bottom?

Actions #5

Updated by Wolfgang Wagner about 1 year ago

I have done this, but it has not given me any improvement. I still get logged out again and again.

Actions #6

Updated by Jan Kiesewetter about 1 year ago

I can confirm this issue. Just tried to edit some content on an up-to-date iPad and get thrown to the login if I close or save an content element.

Actions #7

Updated by Patrick Broens about 1 year ago

I can confirm this issue as well on MacOS Ventura 13.3.1, Safari 16.4, TYPO3 v12.4.1

It's not happening in every module for me, but clicking on the module icon for the new "Reactions" and "Webhooks" always triggers it for me, sometimes other modules. Modals are unusable, since the login screen is in there as well. In modals this also happens always

Opening or closing the DevTools makes no difference for me.

Actions #8

Updated by Benjamin Robinson about 1 year ago

I also have this problem and have been able to isolate the cause. Every time I saved a text element, Safari logged me out. I suspected the rte_ckeditor and found out that the problem does not occur if I do not import the EXT:rte_ckeditor/Configuration/RTE/Editor/Plugins.yaml in my configuration.

Addendum: I was able to narrow this down further: the cause lies with importModules: '@typo3/rte-ckeditor/plugin/typo3-link.js'.

Actions #9

Updated by Patrick Broens about 1 year ago

For me it is not related to CKeditor, since this happens in modules and modals where CKeditor is not loaded at all

Actions #10

Updated by Riccardo De Contardi about 2 months ago

Is this still reproducible? tried with TYPO3 13.2.0-dev and the "Reactions" module and nothing wrong happened

Safari 17.5 on MacOS Ventura (latest release)

Actions #11

Updated by Georg Ringer about 2 months ago

  • Related to Bug #102185: Can't login to typo3 backend on safari added
Actions #12

Updated by Georg Ringer about 1 month ago

  • Status changed from Needs Feedback to Closed

can't be reproduced by issue reporter on 12 anymore, closing issue

Actions

Also available in: Atom PDF