Feature #14277

Start/Stop time for pages is ignored in standard menu objects

Added by Michael Stucki about 15 years ago. Updated 3 months ago.

Status:
Under Review
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2004-08-20
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Since menu objects are normally cached they will not change even if a new page would appear/disappear because the start/stop time was set.

Suggestion: Check start/stop time always, just before the object is fetched from the cache.
(issue imported from #M297)


Related issues

Related to TYPO3 Core - Bug #16815: Sitemap ignoring "Start" and "End" flags Closed 2006-12-28

History

#1 Updated by Thomas Hempel over 13 years ago

Seems to work now. Can't reproduce this with TYPO3 4.0. With enabled cache the pages doesn't appear if the start end/or enddate disables them.

Greets,
Thomas

#2 Updated by Michael Stucki about 13 years ago

I still think there must be a problem with this:

- Imagine you have a page A that is listed in the navigation of page B
- Page A has stop time set to d+1 days
- No notification happens to the cache of Page B

#3 Updated by Sebastian Kurfuerst about 13 years ago

keyword:t3dd06

#4 Updated by Alexander Opitz almost 6 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version changed from 3.6.2 to 3.6

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5 or 6.1)?

#5 Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

#6 Updated by Simon Schaufelberger over 5 years ago

  • Status changed from Closed to New

Hi Alexander, yes this issue still exists, since it is NOT fixed!
Should the sitemap be cached generally? If yes for how long? Should the sitemaps cache get deleted via some logic to delete all sitemap caches whenever a page changes its online status?
Should the sitemap check every page check every single page recursively if the page is currently active?

#7 Updated by Mathias Schreiber over 4 years ago

  • Target version set to 7.2 (Frontend)

#8 Updated by Benni Mack over 4 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)

#9 Updated by Susanne Moog about 4 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#10 Updated by Benni Mack about 4 years ago

  • Target version deleted (7.5)

#11 Updated by Riccardo De Contardi over 1 year ago

This issue is still present on 9.2.0-dev (latest master); it can be easily verified in this way:

1) insert an HMENU TypoScript object in your pages or
1.1) Create a content element "Menu of pages"
2) add to 1) or 1.1) a page with an expiration date/time in the near future
3) open your site with a different browser; you still will see the page in both menus even after the expiration date, until you clear the cache

#12 Updated by Christian von Holten 5 months ago

Still exits in 9.5.7. and i have to clear all caches if a pages will be enabled by starttime. Is there any workaround to disable cache for hmenu or something else? I wonder why I did not noticed such a essential problem in the last 10 years I worked with TYPO3.

#13 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61395

Also available in: Atom PDF