Bug #15951

clickmenu on pagetree icons does not work

Added by Ernst Went almost 14 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2006-03-30
Due date:
% Done:

0%

TYPO3 Version:
4.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

IE: click on pagetree icon produces following js-error:
'null' is Null or no object

Firefox: clickmenu does not show either, no error is generated.

Drag-and-drop of does not work either.

(issue imported from #M3071)


Related issues

Related to TYPO3 Core - Bug #15657: left-click in filelist is broken (IE6) Closed 2006-02-17
Related to TYPO3 Core - Bug #19700: gzip compression does not work in BE Closed 2008-12-15

History

#1 Updated by Franz Holzinger almost 14 years ago

Which versions of IE, Firefox and Windows/LINUX did you test?
Did you update the version in the install tool Update Wizard?
Apply the source ocde of the generated HTML of the page tree as a file.

#2 Updated by Ernst Went almost 14 years ago

Yes, typo3 is running in compatibility mode. IE 6.0 and FF 1.5 is used.
After further research, it turned out, that on another server there were no problems. The faulty server is running on Redhat Linux, PHP Version 4.4.1, Apache/2.0.52 (Unix) DAV/2 PHP/4.4.1 SVN/1.3.0

And Firefox does generate an error (it just wasn't shown at the top right icon):
Error: xml declaration not at start of external entity
Source File: http://alpha.zellwerk.com/ngk/pro/typo3/alt_clickmenu.php?table=pages&uid=54&listFr=0&enDisItems=&backPath=|0d8fab3aae&addParams=&bank=0&ajax=1
Line: 2, Column: 1
Source Code:
^

Apparently there is a line feed inserted before echoing the -tag (Line: 2!!). But according to the code of the function outputXMLreply (class.t3lib_ajax.php) this cannot happen. Confusing.

#3 Updated by Franz Holzinger almost 14 years ago

Maybe a space characted is needed here before the second question mark?

--------------------------------------------
function outputXMLreply($innerXML) {
// AJAX needs some XML data
header('Content-Type: text/xml');
$xml = '
<t3ajax>'.$innerXML.'</t3ajax>';
echo $xml;
}

#4 Updated by Ernst Went almost 14 years ago

Problem solved. There was a user extension, where ext_tables.php had a blank line after the php-code tag "?>".
Very sorry.
Interestingly the same extension didn't throw an error in ver 3.81.

#5 Updated by Joen Weidemann over 13 years ago

Here is what I see using winxp:
-- IE6.0.2900.2180.sp2--
No left-click or right-click menu in icons in right hand pane.
Get this javascript error: Line:143. Char:6. Errir:'null' is null or not an object. Code:0.
FF1.5.0.3
Works fine

#6 Updated by philippe Fronzes over 13 years ago

I had this problem with typo3 4.0 running on IIS6 Webserver, but not on Apache.
I resolve it by adding the charset in the header send by the function outputXMLReply (see below).
This is a workaround for my special case, but i hope it could help for others, and for a complete resolution of the problem.

function outputXMLreply($innerXML) {
// AJAX needs some XML data
header('Content-Type: text/xml; charset=iso-8859-1');
$xml = '
<t3ajax>'.$innerXML.'</t3ajax>';
echo $xml;
}

#7 Updated by Rafael Freuler over 13 years ago

I had the same problem. It turns out that my problem were a couple of empty lines in localconf.php after the closing ?>

#8 Updated by Oliver Hader almost 13 years ago

This issue should be solved in TYPO3 4.1 on using the new AJAX pagetree.

#9 Updated by Steffen Kamper almost 13 years ago

wrong status ?
I don't see the problems in 4.1 RC1

#10 Updated by Benni Mack almost 13 years ago

Is this closed for the 4.1RC2?

#11 Updated by Martin Kutschker almost 13 years ago

Still an issue in 4.1 final?

#12 Updated by Martin Mayrhofer over 12 years ago

The Problem are blank lines behind extensions php files. In my case the problem was in the templavoila file "class.tx_templavoila_handlestaticdatastructures.php" After cleaning this line all was working fine.

The same file works on a Linux server with no problem, on my Winows testsystem I have the problem.

The best way to find the File on a Windows System is to install the filemon program and scan for php files while klicking the button on the icon. The file which is called before \typo3\t3lib\class.t3lib_ajax.php should have the problem

#13 Updated by Steffen Kamper over 12 years ago

i confirm this behavior on a windows installation, using the latest svn-version. i have no contextmenu in Pagetree. There is no JS-Error shown.
I searched for files with trailing lines, but didn't found, also filemon didn't helped here.
Is there any tool for finding php-Files with trimming lines? Is this a php-Bug? I don't understand this, cause there are also Files mixed with html and php-tags that doesn't produce errors.
still searching ...

#14 Updated by daniel pugh over 12 years ago

i have this problem as well. i am running latest version (4.1) - context menu not working on ie7 (vista) or firefox

#15 Updated by Benni Mack over 12 years ago

I got a couple of more questions about this:
  • Does this issue happen only if the german translation is used in the BE or with every BE language?
  • Does this happen with every windows installation or only when IIS is used as webserver?

Couldn't reproduce it with XAMPP with a german BE translation with WIndows XP. Everything was working fine there.

#16 Updated by Benjamin Bergmann over 12 years ago

I still have the problem on a typo3 4.1.2 installation on a linux server w/ apache. client is firefox 2.0.0.6 on win xp. i have tested this also on ie6/7, same problem.
all the tricks above did not work! i have checked every php-file of every extension i have installed and could not find any whitespace after ?>. modifying the outputXMLreply-method adding space-character and charset did not work either.

#17 Updated by Jason Lefkowitz about 12 years ago

I am experiencing the same problem in Firefox 2.0.0.9 after upgrading TYPO3 from 4.0.6 to 4.1.3. We're running on Red Hat Enterprise Linux with MySQL 5 and PHP5.

The Firebug extension traps the following Javascript error when I click on a page icon to bring up the menu:

t3ajax has no properties
http://&lt;mysite&gt;/typo3/alt_db_navframe.php??currentSubScript=ext%2Ftemplavoila%2Fmod1%2Findex.php
Line 116

#18 Updated by Jason Lefkowitz about 12 years ago

Just confirmed that it doesn't work for me in IE7 either. Here's the error:

Line: 116
Char: 6
Error: 'null' is null or not an object
Code: 0

#19 Updated by Benni Mack about 12 years ago

I am about to have look at this again with the next alpha of 4.2 where major improvements to the Clickmenu were made.

Please wait until wednesday and report back if the problem still exists.

#20 Updated by Jason Lefkowitz about 12 years ago

Were you able to confirm the issue Benjamin? Should I be downloading one of the 4.2 alpha copies or something? Let me know...

#21 Updated by Omar Dahan about 12 years ago

Click Menu popup is not working in [typo3 4.1.4], on IE7 and on Firefox, have tried all solutions mentionned, but it was something else...

Using FireBug on Firefox to check JS log, I got this message:
Error: mismatched tag. Expected: </clickmenu>.
Source File: http://www.engineervision.com/typo3/alt_clickmenu.php?table=pages&uid=1&listFr=0&enDisItems=&backPath=|c57686978c&addParams=&amp;bank=0&ajax=1
Line: 66, Column: 3
Source Code:
</noscript>--^

I have resolve it by simply adding an opening corresponding tag, as the closing tag is not generated by code, and it works perfectly!

Add <noscript> between <clickmenu> and <htmltable> inside the "alt_clickmenu.php" line 1204 as follows:

$innerXML = '<data><clickmenu><noscript><htmltable><![CDATA['.$CMtable.']]></htmltable><cmlevel>'.$this->cmLevel.'</cmlevel></clickmenu></data>';

My websites (using TYPO) are:
http://www.dahan.ws/
http://www.engineervision.com/

welcome for any further information,
Thanks for TYPO!

#22 Updated by Benni Mack almost 12 years ago

Hey, can you try this with TYPO3 4.2beta1 again?

#23 Updated by Christoph Koehler almost 12 years ago

I have the same problem in Opera and FF, and it only happens if I set extCache=0 in the install tool.

#24 Updated by Christoph Koehler almost 12 years ago

It was an extension's ext_tables.php file, it had blank lines on the top before the opening php tags.
I wonder if whitespace like that can be trimmed away automatically.

#25 Updated by Patrick Fitz-Simons almost 12 years ago

I can confirm failure of pagetree clickmenu and filelist clickmenu
observed in both IE 6x and Firefox 2x

fresh install of TYPO3 4.2 RC 1
no extensions- added
SERVER: SERVER_SOFTW: Apache/2.2.8 (Unix) mod_ssl/2.2.8 OpenSSL/0.9.8g DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4
CONST: php_sapi_name: cgi-fcgi
OTHER: PHP_VERSION : 5.2.5

-------firebug report:------
top.loadTopMenu is not a function
callURL("table=pages&uid=3&listFr=0&enDisItems=&backPath=|06498ca5b4&addParams=&bank=0")clickmenu.js (line 74)
show("pages", "3", "0", "", "|06498ca5b4", "&bank=0")clickmenu.js (line 47)
showClickmenu("pages", "3", "0", "", "|06498ca5b4", "&bank=0")clickmenu.js (line 218)
onclick(click clientX=0, clientY=0)alt_db_navframe.p... (line 1)
[Break on this error] top.loadTopMenu(this.clickURL + '?' + params);

#26 Updated by Patrick Fitz-Simons over 11 years ago

I reconfirm this issue- in 4.2.0 - seems to be related to setting user settings to start up in page module-
if user tools->user settings->startup-> "Start up in the following module" is set to anything other than " " (blank) the clickmenu fails to pop
--illustrated with two discreet admin user accounts
first one is set as default.. (clickmenu works)
the second set to startup in the page module (js error- reported above)
-- second observation
Once startup page options are changed - altering the startup module results in option stuck -- perpetually set to "about" module- (=js error continues)
I had to click "reset to default values" to return clickmenu function

#27 Updated by Jason Lefkowitz over 11 years ago

Has there been any progress on this issue? It's marked "feedback" but I don't see any patches and I'm still getting this in 4.2.0, using both IE and Firefox...

#28 Updated by Steffen Kamper over 11 years ago

why patch? This is a php-problem.

I confirm that it happens with some ftp-transfer, when i download files from linux server. The files are written with "double lines", so there are some extra lines before or after php-tag.

This cause error in TYPO3 as no header can be sended, this also produces errors in ajax.

I don't see any solution in TYPO3. Maybe there is an external program which can look to all php-files of a directory and remove those empty lines.

#29 Updated by wazzzup over 11 years ago

I had the same problem with my Typo3 installation.

I could solve the problem by uninstalling an extension. The extension overwrites the right-click menu.

greets wazzzup

#30 Updated by Benni Mack over 11 years ago

Hey wazzzup. What extension was it?

#31 Updated by wazzzup over 11 years ago

It was a selfmade extension created with kickstarter.
I didn't want to overwrite the right-click-menu but it automaticaly does.

After i have removed the content-menu code from the extension it worked.

So i guess that some people could have problems also because of an extension.

greets wazzzup

#32 Updated by marianne topping about 11 years ago

Same problem - solved with removing 2 empty lines after ?> in realurl_conf.php

#33 Updated by Andrew Henson about 11 years ago

I just wanted to confirm Marianne's note on solving the problem. I had the same issue with the clickmenu not appearing on a site which uses realurl and the realurl_conf.php file had some blank lines after the closing php tag. Removing those made the menu's work again.

This definitely applies to TYPO3 4.2.2 and 4.2.3

#34 Updated by Dmitry Dulepov about 11 years ago

This issue will be automatically fixed when #19700 is fixed.

#35 Updated by Steffen Kamper about 11 years ago

Dmitry - how does the gzip patch solve issue of extra lines in php-files?

Also available in: Atom PDF