Project

General

Profile

Actions

Feature #16681

closed

C style TypoScript comments with start and end in one line lead to errors

Added by Markus Bucher over 17 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
Start date:
2006-11-01
Due date:
% Done:

100%

Estimated time:
PHP Version:
7.0
Tags:
Complexity:
Sprint Focus:

Description

Comments like this:

/******* Metatags **/
config.meta.keywords = foo, bar

in typoscript are treated like a beginning comment without end. Following code has no influence and is ignored.

(issue imported from #M4453)


Files

4453.patch (439 Bytes) 4453.patch Administrator Admin, 2010-12-02 14:48

Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #16830: Comment in TYPOSCRIPT can prevent T3 from rendering templateClosed2007-01-05

Actions
Related to TYPO3 Core - Bug #76447: TypoScript Parse BugClosed2016-06-03

Actions
Actions #1

Updated by Jacob Floyd over 15 years ago

I can confirm this - I'm using PHP 5.2.6 with typo3 4.2.6

I couldn't figure out for quite a while why a section of my ts wasn't getting through - After moving it above a part that was working, I discovered that it disabled that too - after removing the multiline comment, everything worked as expected. Go figure.

Actions #2

Updated by Benni Mack over 13 years ago

Could you check if the attached patch solved this issue?

Actions #3

Updated by Alexander Opitz about 11 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)

As this report is very old, is the handling in newer TYPO3 CMS Versions (like 6.0/6.1) more like you expect it?

Actions #4

Updated by Chris topher about 11 years ago

  • % Done changed from 0 to 100

Markus Bucher wrote:

Comments like this:

/******* Metatags **/
config.meta.keywords = foo, bar

in typoscript are treated like a beginning comment without end.

Sidenote: This is no bug, but exactly the documented behavior. Your comment block needs to be closed with "*/" signs at the beginning of a new line. Put the "*/" signs on a new line or - as you only have one line of comment anyway - use a normal one-line comment like "# Comment" and things should be working.

Actions #5

Updated by Chris topher about 11 years ago

  • % Done changed from 100 to 0
Actions #6

Updated by Alexander Opitz about 11 years ago

  • Status changed from Needs Feedback to Rejected

No bug as documented.

Actions #7

Updated by Ingo Renner about 11 years ago

  • Tracker changed from Bug to Feature
  • Status changed from Rejected to New
  • Assignee deleted (Benni Mack)

re-opening. I think it's a valid issue and a low hanging fruit to ease live. If we support /* ... */, why not support it for single line comments? Also the patch on first sight looks like it would solve the issue.

Actions #8

Updated by Mathias Schreiber over 9 years ago

  • Target version set to 7.2 (Frontend)
Actions #9

Updated by Benni Mack about 9 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)
Actions #10

Updated by Susanne Moog almost 9 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #11

Updated by Benni Mack almost 9 years ago

  • Target version changed from 7.5 to 8 LTS
Actions #12

Updated by Riccardo De Contardi over 8 years ago

  • Category set to TypoScript
Actions #13

Updated by Riccardo De Contardi over 7 years ago

  • Target version changed from 8 LTS to 9 LTS
  • PHP Version changed from 4.3 to 7.0
Actions #14

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57763

Actions #15

Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57763

Actions #16

Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57763

Actions #17

Updated by Markus Klein almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #18

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF