Project

General

Profile

Actions

Bug #17201

closed

Preview link does not preview all template "type"s..

Added by Andreas Balzer about 17 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2007-04-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi!
Imagine the following situation:
You have pagetype type = 0 for your contents. The template with pagetype 0 includes the same page (via a link tag) with page type 1, which is storing the css.

If you have a page with this template arrangement in your workspaces and create a preview link to send it to someone, he'll only be able to see pagetype 0. The same page but pagetype 1 is not previewable, which breaks the website, as the css is not shown.

As I didn't find any config setting, I assume this is a bug.

T3 4.1
PHP 5
modern template building used
Fx and IE7 browser affected, but I guess it's not a clientside problem..
(issue imported from #M5401)

Actions #1

Updated by Martin Kutschker about 17 years ago

I don't think that using a page type for delivering the CSS is very common setup.

Actions #2

Updated by Andreas Balzer about 17 years ago

This might be correct, but what about XML or other configurations? Imagine you're using a flash site. It wouldn't work too...

Actions #3

Updated by Martin Kutschker about 17 years ago

I see. But how should this work? I can more or less imaging that the make-preview-link makes a copy (or whatever it does) for all configured page types. But how shall TYPO3 automagically change all required links?

While interesting in way I think there are more issues and bugs with WS than this.

Actions #4

Updated by Andreas Balzer about 17 years ago

Maybe T3 can check, whether the current page was accessed with a preview url. If this happend, it could check the ids for the current page and automatically allow the current user to see the other pagetypes of the current page (with the original urls).

I agree that there are a lot of other bugs, but as my editors noticed this one, I posted it.

Actions #5

Updated by Benjamin Fischer about 17 years ago

I can reproduce this error on a frame based website.

The preview/compare function between Live and Draft-Workspace does not work. Both screens always show the same version, either the Draft preview (if Frontend Preview is activated in the Workspace) or the Live Version.

This makes the preview/compare function unusable for setups with more then one page type.

Best Regards, Benjamin

Actions #6

Updated by Michael Stucki over 10 years ago

  • Category changed from Miscellaneous to Workspaces
Actions #7

Updated by Michael Stucki over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
  • Target version deleted (0)
Actions #8

Updated by Mathias Schreiber over 9 years ago

  • Target version set to 7.5
Actions #9

Updated by Benni Mack almost 9 years ago

  • Target version changed from 7.5 to 7 LTS
Actions #10

Updated by Mathias Schreiber over 8 years ago

  • Description updated (diff)
  • Target version deleted (7 LTS)
  • Is Regression set to No
Actions #11

Updated by Georg Ringer over 8 years ago

  • Status changed from New to Closed

i am closing this issue because using multiple page types or frames is not the current way to build websites anymore. a lot changed also in preview of workspaces

Actions

Also available in: Atom PDF