Bug #20611

deprecated function in class.nusoap.php in TYPO3 v.4.3alpha3

Added by David Bruchmann over 12 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extension Manager
Target version:
-
Start date:
2009-06-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Info of PHP 5.3:
Deprecated: Assigning the return value of new by reference is deprecated in ...\typo3\mod\tools\em\class.nusoap.php on line 5440

(issue imported from #M11320)


Related issues

Related to TYPO3 Core - Feature #19791: Use native SoapClient implementation of PHP5 onlyClosedMarcus Krause2009-01-11

Actions
Related to TYPO3 Core - Bug #21044: Do not show E_DEPRECATED messages on productive systemsClosedRupert Germann2009-09-12

Actions
Related to TYPO3 Core - Bug #22188: Upload to TER uses deprecated function set_magic_quotes_runtimeClosed2010-02-25

Actions
Has duplicate TYPO3 Core - Bug #21038: Deprecated: Assigning the return value of new by reference is deprecated in .../typo3/mod/tools/em/class.nusoap.php on line 5436ClosedOliver Hader2009-09-12

Actions
#1

Updated by Marcus Krause over 12 years ago

I'm curious; how did you stumble over this issue? Did TYPO3 actually executed this code?

I'm asking as there was a discussion recently about removing nusoap completely.

#2

Updated by David Bruchmann over 12 years ago

I just turned on some debugging, that's all.
PHP did show the hint on several frames in BE.

#3

Updated by Steffen Kamper over 12 years ago

this is strange. There is no call, the only occurance i found is here:
// Avoid autoloading "soapclient", since it's only a strategy check here:
$content = (!defined('SOAP_1_2') && class_exists('soapclient', false)) ? base64_encode($infoArr['content']) : $infoArr['content']; // bug in NuSOAP - no automatic encoding

in class.em_terconnection.php

But there is no reference to the nusoap class. To be sure i renamed the file and tested EM again, without any error.
Why don't we remove this file?

#4

Updated by Marcus Krause about 12 years ago

Actually, I made an effort to remove nosoap completely in #19791. See also core list.
@see http://lists.netfielders.de/pipermail/typo3-team-core/2009-January/022233.html

#5

Updated by Franz Holzinger almost 12 years ago

This warning is shown in the EM's list of extensions.

#6

Updated by Benni Mack almost 12 years ago

Does this problem still occur with the latest TYPO3 4-3 version?

Please check.

#7

Updated by Stefan Neufeind over 10 years ago

TYPO3 v4.5+ does not ship with nusoap anymore.

Assignment by refernece was fixed for 4.3 between 4.3.0alpha3 and 4.3.0beta1 with:
commit f32a015e4162f2aa39b383e50f88ef342caaac1c
Author: Oliver Hader <>
Date: Fri Sep 18 10:44:02 2009 +0000
Follow-up to bug #11831: Removed reference operator from an object
git-svn-id: https://svn.typo3.org/TYPO3v4/Core/trunk@5974 709f56b5-9817-0410-a4d7-c38de5d9e867

- $this->wsdl =& new wsdl($this->wsdlFile,$this->proxyhost,$this->proxyport,$this->proxyusername,$this->proxypassword,$this->timeout,$this->response_timeout);
+ $this->wsdl = new wsdl($this->wsdlFile,$this->proxyhost,$this->proxyport,$this->proxyusername,$this->proxypassword,$this->timeout,$this->response_timeout);

#8

Updated by Xavier Perseguers over 10 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (0)
  • % Done changed from 0 to 100

Also available in: Atom PDF