Bug #21059

Not possible to install a sysext with Extension manager

Added by Georg Ringer over 11 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2009-09-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

It seems that it is not possible to install a sys ext through the Extension manager.

it seems the check fails in class.em_index.php #15203
if (!$EM_CONF['lockType'] || !strcmp($EM_CONF['lockType'],$loc)) {

$EM_CONF['lockType'] => system
$loc => S

(issue imported from #M11960)

#1

Updated by Oliver Hader over 11 years ago

Hi Georg,
did you want to upload/upgrade an extension or just install/enable?

#2

Updated by Georg Ringer over 11 years ago

hi! i tried to upload + install an sys ext through the EM and of course I set in install tool that exts can be installed in typo3/sysext

#3

Updated by Susanne Moog over 9 years ago

  • Status changed from Needs Feedback to New
  • Assignee changed from Oliver Hader to Steffen Kamper
  • Target version deleted (0)
  • TYPO3 Version changed from 4.3 to 4.5

I can't reproduce this with the old extension manager. However I can't install as a system or global extension with the new extension manager, so I'll leave this bug open for the new ext mgm.

#4

Updated by Helmut Hummel over 9 years ago

  • Target version set to 4.6.0-RC1
#5

Updated by Steffen Gebert over 9 years ago

Why can't you install a system extensions? I have no problems..

#6

Updated by Dmitry Dulepov over 9 years ago

I have a related problem.

When I upload the file, I have only "Local" as the install option.

I enabled System and Global in the Install tool and permissions to typo3/ext and typo3/sysext are set to 0777.

#7

Updated by Felix Kopp over 9 years ago

What about removing the Global option at all?
Local should be sufficient.

Removal is easy and could be done for 4.6 also.

#8

Updated by Xavier Perseguers over 9 years ago

  • Target version changed from 4.6.0-RC1 to 4.6.0
#9

Updated by Chris topher over 9 years ago

  • Target version changed from 4.6.0 to 4.6.1
#10

Updated by Chris topher over 9 years ago

  • Target version changed from 4.6.1 to 4.6.2
#11

Updated by Xavier Perseguers about 9 years ago

  • Assignee deleted (Steffen Kamper)
  • Target version deleted (4.6.2)
#12

Updated by Georg Ringer over 8 years ago

  • Status changed from New to Closed

not relevant anymore, 2 ems later

Also available in: Atom PDF