Bug #24865

Standalone images in RTE-enabled field not rendered in frontend

Added by Peter L over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2011-01-27
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After upgrade to 4.5.0 i have a problem, that all images in frontend missing, that are allone in a p-tag.

<p><img height="156" width="125" src="uploads/bla.jpg" /></p>
showing:
<p> </p>

but when something else is inside the paragraph, the image will be shown:
<p>test1234<img height="156" width="125" src="uploads/bla.jpg" /></p>

(issue imported from #M17373)

typo3core_bugfix_17373_trunk.patch View (618 Bytes) Administrator Admin, 2011-01-28 22:59

typo3core_bugfix_17373_typo3_4-4.patch View (610 Bytes) Administrator Admin, 2011-01-28 23:12


Related issues

Related to TYPO3 Core - Bug #17433: Inserting a divider (<hr>) on the RTE breaks XHTML validation Closed 2007-07-04
Duplicated by TYPO3 Core - Bug #24991: Some images not rendered in frontend, but visible in RTE Closed 2011-02-09

History

#1 Updated by Peter L over 8 years ago

html is not good here, i try with []:

in RTE the html-source is:
[p][img height="156" width="125" src="uploads/bla.jpg" /][/p]

the website output is:
[/p]

but when something else is inside the paragraph, the image will be shown:

[p]test1234[img height="156" width="125" src="uploads/bla.jpg" /][/p]

#2 Updated by Jo Hasenau over 8 years ago

Are we talking about standard images or is this about images within RTE text paragraphs?

#3 Updated by Peter L over 8 years ago

Images in RTE text paragraphs.

#4 Updated by Chris topher over 8 years ago

I can reproduce this problem.

For me it also occurs, if the image is the only tag inside a td tag.

When I view the source of an affected content element in the RTE, the path to the image is shown correctly like http://localhost/fileadmin/user_upload/Picture.jpg. Opening that picture with the browser directly works.

#5 Updated by Peter L over 8 years ago

I reviewed the problem, but i couldn't find the causation. Here my summary:

In the SQL-Database the recordset looks like this:
[img height="156" width="125" src="uploads/bla.jpg" /]

The RTE-Editor showing the image. The html-source is this (RTE added automaticly the p-tags):
[p][img height="156" width="125" src="uploads/bla.jpg" /][/p]

on the website output is:
[/p]

only when something added to the line with image, the output works fine.
[img height="156" width="125" src="uploads/bla.jpg" /] test123

on the website output is:
[p][img height="156" width="125" src="uploads/bla.jpg" /] test123[/p]

#6 Updated by Chris topher over 8 years ago

The database record seems to be OK.
The problem is somewhere in the rendering. I don't know...

#7 Updated by Stanislas Rolland over 8 years ago

Using the TypoScript Object Browser on the page that is being rendered, please report whatever you have under
lib.parseFunc_RTE.tags.img ?

#8 Updated by Chris topher over 8 years ago

Hi Stan,

I only have lib.parseFunc_RTE.tags.link.{....}.
In my case there is nothing set under lib.parseFunc_RTE.tags.img.

#9 Updated by Stanislas Rolland over 8 years ago

Problem in t3lib_cObj::encaps_lineSplit.

I expect the same to occur with current SVN branch TYPO3_4-4.

#10 Updated by Jeff Segars over 8 years ago

Just to add another data point, I can confirm the issue with 4.5 and the current SVN checkout of 4.4

#11 Updated by Stanislas Rolland over 8 years ago

The attached patch fixes this issue. Please confirm.

#12 Updated by Jeff Segars over 8 years ago

Yep, fixes it for me too in 4.4 and 4.5. Thanks for the quick patch!

#13 Updated by Peter L over 8 years ago

Fixes my problem, too. Thank you!

#14 Updated by Steffen Gebert over 8 years ago

same here, thanks Stan!

#15 Updated by Chris topher over 8 years ago

Yes, with the patch it works again. Thank you, Stan!

#16 Updated by Stanislas Rolland over 8 years ago

Committed to SVN TYPO3core trunk (revision 10358), branch TYPO3_4-5 (revision 10359) and branch TYPO3_4-4 (revision 10360).

#17 Updated by Susanne Moog over 8 years ago

  • Target version deleted (4.4.7)

Also available in: Atom PDF