Bug #25213

Install Tool allows editing settings added by extensions duplicating them on the way

Added by Tobias Schaefer almost 10 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Install Tool
Target version:
-
Start date:
2011-03-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

When I save 'Install Tool' / 'All Configuration', I get (while not having changed anything!):
$TYPO3_CONF_VARS['FE']['defaultTypoScript_constants'] = '[GLOBAL]\' . LF . \'extension.pdf_generator2.typeNum = 123';

This was already fixed with the patch of bug #21501 and TYPO3 4.4.1. but somehow the bug still occurs in TYPO3 4.4.7.

1) I have installed "pdf_generator2" that does
t3lib_extMgm::addTypoScriptConstants('extension.pdf_generator2.typeNum = 123");
in ext_localconf.php
2) Every save in 'Install Tool' / 'All Configuration' duplicates the contents of $TYPO3_CONF_VARS['FE']['defaultTypoScript_constants']
(issue imported from #M17813)


Related issues

Related to TYPO3 Core - Bug #21501: Install Tool duplicates values of textarea fieldsClosedSteffen Kamper2009-11-09

Actions
Related to TYPO3 Core - Bug #23929: Install tool: defaultTypoScript_setup should be textareaClosedSteffen Gebert2010-11-03

Actions
Related to TYPO3 Core - Bug #24129: Installer - All Configuration - [default TS setup] is a input field instead of a teaxtareaRejected2010-11-18

Actions
Precedes TYPO3 Core - Bug #35410: PHP warning: Unknown modifier 'r' in tx_installClosedJigal van Hemert2012-03-30

Actions
#1

Updated by Clemens Riccabona almost 10 years ago

same here on a 4.5.0, 4.5.1 and 4.5.2 and a 4.4.5

and i can NOT confirm this have ever been fixed in a official TYPO3 release (but i did not try every service release since this anoying problem occurred).

#2

Updated by Tobias Schaefer almost 10 years ago

i've looked at the affected files from patch 12514_v3.diff and it seems that the code changes applied by this patch is in the core of 4.4.7. So, I assume that patch 12514 doesn't really do what it is supposed to do.

#3

Updated by Simon Schaufelberger almost 9 years ago

  • Target version deleted (0)

Hi,
This issue is still valid for 4.5.10 and is so annoying.

#4

Updated by Clemens Riccabona almost 9 years ago

Yes Please, it is really much anoying!

#5

Updated by Ernesto Baschny almost 9 years ago

  • Subject changed from Install Tool duplicates values of textarea fields to Install Tool allows editing settings added by extensions duplicating them on the way
  • Category set to Install Tool
  • Status changed from New to Accepted
  • Assignee set to Ernesto Baschny
  • Complexity set to medium

The problem is not of duplicating "multi-line fields" (as it was before, and fixed in the mentioned issue #21501).

In this case the problem is that the Install Tool is allowing to edit settings which are added by Extensions (through e.g. t3lib_extMgm::addTypoScriptSetup). These additions are appended to existing settings. So each time you edit and save these again, more and more lines will be generated.

Solution is to track the settings which are added by extensions (through the API) and don't allow to edit this specific snippets.

#6

Updated by Gerrit Code Review almost 9 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8704

#7

Updated by Gerrit Code Review almost 9 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8704

#8

Updated by Ernesto Baschny almost 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#9

Updated by Clemens Riccabona almost 9 years ago

I am happy to see this in a most likley coming 4.5.12 release - finally! :-)

Thanks a lot, Ernesto!

#10

Updated by Simon Schaufelberger almost 9 years ago

Thank you from me as well!

#11

Updated by Steffen Gebert over 8 years ago

This change causes a PHP Warning. As I don't understand the code, it would be nice, if the authors could have a look at #35410.

#12

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/11321

#13

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/11324

#14

Updated by Christian Kuhn over 8 years ago

  • Status changed from Under Review to Resolved
#15

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/13256

#16

Updated by Wouter Wolters over 7 years ago

  • Status changed from Under Review to Resolved

Accidently reopened by Gerrit script

#17

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF