Project

General

Profile

Actions

Bug #25554

closed

Handling of tab indentation is faulty

Added by Administrator Admin over 14 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Won't have this time
Assignee:
-
Category:
t3editor
Target version:
-
Start date:
2009-06-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When opening a TS record in TCEforms (list module f.e.) and indenting lines with tab, these indentations are "gone" (visually) in t3editor.

When indenting with tab in t3editor, tabs are converted to two spaces when opening the TS record in TCEforms again.

Found that behavior in FF3.5

(issue imported from #M11454)


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Task #28853: Upgrade CodeMirror to 3.0Closed2011-08-08

Actions
Related to TYPO3 Core - Feature #81901: Refactor t3editorClosedAndreas Kienast2017-07-17

Actions
Actions #1

Updated by Ingmar Schlecht over 13 years ago

I can confirm that. Tabs seem to be converted to spaces even for lines that haven't been touched, which is quite unexpected I would day...

Actions #2

Updated by Tobias Liebig almost 13 years ago

  • Status changed from Accepted to New
  • Assignee deleted (Administrator Admin)
  • Priority changed from Should have to Won't have this time
  • Target version deleted (0)
  • TYPO3 Version set to 4.5

The Problem ist, that the CodeMirror converts tabs into spaces. It does for a reason, because handling "tabs" seems not to work out in a editable iframe.

CodeMirror2 addresses this issue, but it not stable or feature complete yet.

Actions #3

Updated by Michael Stucki about 10 years ago

  • Project changed from 75 to TYPO3 Core
Actions #4

Updated by Michael Stucki about 10 years ago

  • Category set to t3editor
Actions #5

Updated by Mathias Schreiber about 9 years ago

  • Description updated (diff)
  • Is Regression set to No

any progress here?

Actions #6

Updated by Riccardo De Contardi almost 8 years ago

As far as I can see the version of codemirror shipped with TYPO3 8.2 is still version 0.9.4

Actions #7

Updated by Georg Ringer over 6 years ago

Actions #8

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 27 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53413

Actions #9

Updated by Andreas Kienast over 6 years ago

This issue is fixed since #81901, available with the upcoming v9.

Actions #10

Updated by Andreas Kienast over 6 years ago

  • Status changed from Under Review to Rejected
Actions

Also available in: Atom PDF