Project

General

Profile

Actions

Bug #27131

closed

Publishing a page does not delete cache_treelist entry

Added by Thomas Trethan about 13 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
Start date:
2011-05-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Publishing a page does not delete any cache_treelist entries. Here's what I traced:

tx_Workspaces_ExtDirect_ActionHandler.sendToNextStageExecute()
t3lib_TCEmain.process_cmdmap()
tx_cms_treelistCacheUpdate.processCmdmap_postProcess()

I think the problem ist, that the new workspace module uses process_cmdmap, which tx_cms_treelistCacheUpdate only hooks into for deleted pages. So the version-command is totally ignored.

Don't know, whether this is a Workspace or Core bug...

Regards, Tom


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #37952: Treelist cache is not cleared after publishingClosed2012-06-12

Actions
Actions #1

Updated by Thomas Trethan about 13 years ago

Temporarily fixed it by modifying processCmdmap_postProcess():

if ($table 'pages' && ($command 'delete' || ($command 'version' && $commandValue['action'] 'swap'))) {

Actions #2

Updated by Michael Klapper about 13 years ago

  • Status changed from New to Needs Feedback

Hi Tom,
how can i reproduce this?
Cheers
Mick

Actions #3

Updated by Michael Klapper almost 13 years ago

  • Status changed from Needs Feedback to Accepted

I only see that issue if an page is deleted in workspace, after puplish the page tree should update the tree.

Actions #4

Updated by Thomas Trethan almost 13 years ago

strange that it doesn't happen to you
I don't know what to tell you how to reproduce it, it simply happens with my installation
maybe any other circumstances cause this problem
I did a lot of debugging to come to the conclusion as mentioned in the description, but maybe the real reason is somewhere else?
could you tell me at which position in the source code the tree list cache should be updated on publishing a page in a workspace?
then I could check what why this particular code is not executed in my setup

Actions #5

Updated by Jose Antonio Guerra over 11 years ago

This is a duplicate of #37952

Actions #6

Updated by Michael Stucki over 10 years ago

  • Category changed from Bugs to Workspaces
Actions #7

Updated by Michael Stucki over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
Actions #8

Updated by Mathias Schreiber over 9 years ago

  • Target version set to 7.5
Actions #9

Updated by Bart Dubelaar almost 9 years ago

  • Status changed from Accepted to Resolved
Actions #10

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF