Bug #29788

Cannot close window after having installed another depending extension

Added by Robert Wildling over 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2011-09-14
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If an ext needs another ext to be installed, a new window can be opened where the installation can be done. But the close window link on that respective page doesn't work.

Tested and reproduced on Mac 10.7.1 with MAMP 2.0.3 (php 5.2) and FF 6.0.1, Chrome 13.0.782, Opera 11.51 and Safari 5.1 (with "New window in Tab" and "New Window opens in new Window")

(At the moment (Typo3 4.5.6, Sept 14 2011, 8.19 pm), indexed-search cannot retrieve the depending ext doc_indexed_search from the TER. Maybe this is another bug closely connected to this one, because the TER itself is online and the respective ext is available...)


Related issues

Related to TYPO3 Core - Bug #30606: Close window and recheck dependencies does not work Closed 2011-10-06

Associated revisions

Revision 7c26376f (diff)
Added by Kay Strobach over 8 years ago

[BUGFIX] EM: Fix button "close window" after fulfilling dependencies

This fix opens the window in a sized window and changes the logic to
determine the correct function for closing the window.

Change-Id: Ie16d67284240a833e5bfae67d8b78eab808f9a79
Releases: 4.6
Resolves: #29788
Reviewed-on: http://review.typo3.org/5706
Reviewed-by: Xavier Perseguers
Tested-by: Xavier Perseguers
Reviewed-by: Jigal van Hemert
Tested-by: Jigal van Hemert

History

#1 Updated by Steffen Gebert over 8 years ago

  • Priority changed from Must have to Should have
  • Target version deleted (4.5.7)

#2 Updated by Steffen Ritter over 8 years ago

this is an issue due to the new Extensions-Manager.
The close link of such window, issue only a JS command to thew new EM - this does not work anymore when using the old em

#3 Updated by Helmut Hummel over 8 years ago

  • Target version set to 4.6.0-RC1
  • TYPO3 Version changed from 4.4 to 4.5

This also happens in the new EM, as the new EM also opens a new window when installing a dependent extension

#4 Updated by Helmut Hummel over 8 years ago

  • Subject changed from EM (old version) cannot close window after having installer another depending extension to Extension Manager: Cannot close window after having installer another depending extension

#5 Updated by Helmut Hummel over 8 years ago

  • Target version changed from 4.6.0-RC1 to 4.5.7

#6 Updated by Helmut Hummel over 8 years ago

  • Priority changed from Should have to Must have

#7 Updated by Steffen Gebert over 8 years ago

  • Target version changed from 4.5.7 to 4.6.0-RC1

Helmut, I'd like to set the target version to 4.6.0-RC1, as these are the issues, on which we (or at least me) currently have an eye on. It would be a no-go, to deliver a 4.6 with this bug.

#8 Updated by Xavier Perseguers over 8 years ago

This is a bug for sure and will be fixed of course but to be honest, it's not blocking at all ;-)

#9 Updated by Oliver Hader over 8 years ago

  • Subject changed from Extension Manager: Cannot close window after having installer another depending extension to Cannot close window after having installed another depending extension

#10 Updated by Oliver Hader over 8 years ago

  • Status changed from New to Accepted

#11 Updated by Mr. Hudson over 8 years ago

Patch set 1 of change Ie16d67284240a833e5bfae67d8b78eab808f9a79 has been pushed to the review server.
It is available at http://review.typo3.org/5706

#12 Updated by Mr. Hudson over 8 years ago

Patch set 2 of change Ie16d67284240a833e5bfae67d8b78eab808f9a79 has been pushed to the review server.
It is available at http://review.typo3.org/5706

#13 Updated by Xavier Perseguers over 8 years ago

  • Status changed from Accepted to Under Review

#14 Updated by Mr. Hudson over 8 years ago

Patch set 3 of change Ie16d67284240a833e5bfae67d8b78eab808f9a79 has been pushed to the review server.
It is available at http://review.typo3.org/5706

#15 Updated by Mr. Hudson over 8 years ago

Patch set 4 of change Ie16d67284240a833e5bfae67d8b78eab808f9a79 has been pushed to the review server.
It is available at http://review.typo3.org/5706

#16 Updated by Mr. Hudson over 8 years ago

Patch set 5 of change Ie16d67284240a833e5bfae67d8b78eab808f9a79 has been pushed to the review server.
It is available at http://review.typo3.org/5706

#17 Updated by Mr. Hudson over 8 years ago

Patch set 6 of change Ie16d67284240a833e5bfae67d8b78eab808f9a79 has been pushed to the review server.
It is available at http://review.typo3.org/5706

#18 Updated by Xavier Perseguers over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#19 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF