Bug #32406

Menus not working in translated pages for type "shortcut"

Added by Gonçal Carrero over 10 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2011-12-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

After upgrade to version 4.6 in an old typo3 install we have been having problems with a translated site. The problem is some menus were not generated. After a deep search we found that it was only in the shortcut pages. We have seen the problem comes from the pageOverlayFields variable that comes by default in newer versions. Some of the fileds that weren't before are shortcut and shortcut_mode, and these seems to be the problem. We have deleted these fields in the install tool $TYPO3_CONF_VARS['FE']['pageOverlayFields'] and now it seems to be working perfectly.

The question is, why those fields are in the config_default file now and not where in the old versions, and are they really needed?


Related issues

Related to TYPO3 Core - Bug #28686: menu generation for shortcuts on translated pages broken.Closed2011-08-02

Actions
Related to TYPO3 Core - Bug #60382: Shortcut is displayed like a regular page if isn't a shortcut in the original languageRejected2014-07-18

Actions
Has duplicate TYPO3 Core - Bug #33333: shortcut in other language not workingClosed2012-01-20

Actions
Has duplicate TYPO3 Core - Bug #33428: BE: if create shortcut page translation lose target pageClosed2012-01-25

Actions
Blocked by TYPO3 Core - Feature #16935: Add an option to add alternative external URL or shortcut for other languagesClosedIngo Renner2007-02-02

Actions
#1

Updated by Markus Klein over 10 years ago

Those fields where added in February 2009 for TYPO3 4.3.
The reasons are available here: http://forge.typo3.org/issues/16935

Maybe the change for 4.6 how shortcuts are treated causes this behavior.

#2

Updated by Gonçal Carrero over 10 years ago

Markus Klein wrote:

Those fields where added in February 2009 for TYPO3 4.3.
The reasons are available here: http://forge.typo3.org/issues/16935

Maybe the change for 4.6 how shortcuts are treated causes this behavior.

Ok, I understand. I've come back to see what was happening to the alternative page language. What I've seen is that when you come from an update from an old typo3 and the page is a shortcut, in the alternative page language the page type is still standard page.

May be the upgrade wizard must solve this incongruence or in any case advert for this.

#4

Updated by Ernesto Baschny over 10 years ago

  • Category set to Frontend
  • Status changed from New to Accepted
  • Complexity set to medium

As mentioned already in the (now closed duplicate) #33333:

How to reproduce in the intro-package:

- Unter "Examples > Language" create 2 pages "Page 1" and "Page 2"
- Make "Page 1" a shortcut to "Page 2"
- Create translation pages for both pages (Dansk)
- Go to the frontend to the "Examples > Any language" Page
- See both sub-pages are correctly linked
- Switch to "Dansk": First page is not linked correctly anymore (starting with TYPO3 4.6)

Strange enough, this is not a problem in current master (future 4.7) anymore, so somehow it got fixed, but I could localize the fix yet. So it a 4.6 only problem currently.

#5

Updated by Ernesto Baschny over 10 years ago

  • Subject changed from Menus not working in translated pages to Menus not working in translated pages for type "shortcut"
#6

Updated by Kai about 10 years ago

Same after Update from 4.5 to 4.7.2

All translation pages type shortcut are not working anymore. They are all back to page type standard.

#7

Updated by Max Roesch about 10 years ago

Same after Update from 4.5 to 4.7.2

New tranlations of shortcuts only work if the target is set manually. No fallback to origin target, even though it's shown in the backend. Frontend just renders empty a-Tag with translated shortcut title

#8

Updated by Markus Klein about 10 years ago

Sorry for the negative vote. That happened by accident. Unfortunately I'm not able to remove my vote again.

#9

Updated by Joachim King over 9 years ago

I seem to have the same bug in a 6.0.4 project (new site, no update). Can someone confirm the bug in 6.0?

Shortcut pages don't get linked in menue. The solution was to remove "shortcut" and "shortcut_mode" from $TYPO3_CONF_VARS['FE']['pageOverlayFields']. Thanks @ Goncal!

#10

Updated by Roman Eberle about 8 years ago

bug confirmed for 6.1.8

...well - bug or feature? lol

I consider it a bug:
translation of shortcut should be created as shortcut with same shortcut-mode/-target (by default)

not a bug:
you may still switch settings in translated record (in other words: keep "shortcut" and "shortcut_mode" in $TYPO3_CONF_VARS['FE']['pageOverlayFields'])

(hi JKI :-))

#11

Updated by Markus Klein almost 8 years ago

  • Status changed from Accepted to Needs Feedback
  • Is Regression set to No

Can't reproduce this on current master (Version 7).

pageOverlayFields contains shortcut and shortcut_mode.

#12

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF