Bug #33592

Moved translated content elements are in wrong colpos

Added by Georg Ringer about 9 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2012-02-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Imagine 2 pages, both with a page_language_overlay and a contentelement with a language overlay.

If a content element in sys_language=0 is moved to the 2nd page, the page module shows both new content elements in sys_language = 0. If the one content element which has been moved and is a translation, is opend, then english is selected as language (so this is correct).

IMO there are 2 possible places where this can be fixed:
- Adopt the page module, imo the place is in tx_cms_layout.php
- or better idea: a moved placeholder should not loose its colPos


Related issues

Has duplicate TYPO3 Core - Bug #33594: Missing argument 4 for t3lib_TCEmain::moveL10nOverlayRecords(), called in ...version\class.tx_version_tcemain.php on line 1376 Closed2012-02-01

Actions
#1

Updated by Georg Ringer about 9 years ago

oh sorry, its about the sys_language_uid

the record with info "MOVE-TO PLACEHOLDER for #5610" should also have the sys_language_uid of the original and not 0

#2

Updated by Stefan Neufeind about 9 years ago

Could it be this is related to #32967 which aims to fix an issue with colPos on publish? For that there is a patch in gerrit already. Please have a look.

#3

Updated by Georg Ringer about 9 years ago

no sorry it is about the sys_language_uid.

how to test:
  1. Go to live workspace and create 2 pages, on both a content element
  2. (Still in live) translate pages + content elements
  3. Switch to draft ws
  4. cut one one content element and paste it after the another one at the other page
  5. you will see that the translated content element got moved too (which is correct) but the translated content element is shown in default language!
#4

Updated by Gerrit Code Review about 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8997

#5

Updated by Gerrit Code Review about 9 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8998

#6

Updated by Stanislas Rolland about 9 years ago

The problem is that the place holder for the translated element is in the default language.

The proposed change does not modify the reported behaviour.

#7

Updated by Gerrit Code Review almost 9 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8998

#8

Updated by Tolleiv Nietsch almost 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#9

Updated by Gerrit Code Review almost 9 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/9473

#10

Updated by Tolleiv Nietsch almost 9 years ago

  • Status changed from Under Review to Resolved
#11

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 4.6 has been pushed to the review server.
It is available at http://review.typo3.org/11684

#12

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch 4.5 has been pushed to the review server.
It is available at http://review.typo3.org/11707

#13

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/13009

#14

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/13010

#15

Updated by Tolleiv Nietsch over 8 years ago

  • Status changed from Under Review to Resolved
#16

Updated by Michael Stucki about 7 years ago

  • Category set to Workspaces
#17

Updated by Michael Stucki about 7 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces
#18

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF