Feature #34362

Filelist "Date" is not shown from folders

Added by Georg Ringer about 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2012-02-27
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

current master shows the date of folders, fal doesn't in filelist module


Related issues

Duplicates TYPO3 Core - Task #65165: Show folders creation date in Filelist (Backend) Closed 2015-02-19

History

#1 Updated by Benni Mack about 7 years ago

  • Target version set to 6.0 final

#2 Updated by Andreas Wolf about 7 years ago

  • Status changed from New to Accepted

The folder object currently does not expose this information, and it also has very little information about a folder in general. I think we should improve this, maybe by extracting common functionality from the file object to a common base class for files and folders. This class should be like the ResourceInterface, and ideally implement all its methods. The other classes (File, Folder) then inherit this class and add their respective interfaces.

#3 Updated by Alexander Opitz about 5 years ago

  • Tracker changed from Bug to Feature
  • Project changed from File Abstraction Layer to TYPO3 Core
  • Target version deleted (6.0 final)

#4 Updated by Alexander Opitz about 5 years ago

  • Category set to File Abstraction Layer (FAL)
  • TYPO3 Version set to 6.0

#5 Updated by Mathias Schreiber about 4 years ago

  • Status changed from Accepted to Needs Feedback
  • Assignee set to Mathias Schreiber

Where can we take that Information from?
file_mtime or something TYPO3-related like tstamp?

#6 Updated by Susanne Moog over 3 years ago

  • Status changed from Needs Feedback to Closed

Duplicate of #65165 which has a pending patch. I'll close this one.

Also available in: Atom PDF