Bug #37938

Using HTML5 for audio not (easily) possible due to flexform

Added by Stefan Neufeind about 10 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2012-06-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In typo3/sysext/cms/flexform_media.xml the checkbox to use "HTML5/accessible rendering" is only shown if the Media-type is video. It is hidden for audio through a displayCond in flexform.

But that checkbox is needed for HTML5-audio as well. Unfortunately that displayCond can not just be removed since another tab is also triggered by this checkbox:

<TCEforms>
<sheetTitle>LLL:EXT:cms/locallang_ttc.xml:media.tabVideoAccessible</sheetTitle>
<displayCond>FIELD:sGeneral.mmUseHTML5:=:1</displayCond>
</TCEforms>

And displayCond does not allow to have two conditions / one condition of two parts (type=video and mmUseHTML5) here.

Workaround is to use use type=video, check the checkbox and after that change to type=audio. That value is then still present in flexform.

Tested this on latest 4.7.2-dev from git.

PS: CCing Steffen Ritter on this since that condition was introduced by his changeset.

commit 37d6509eff1e9d4eeb2b8e3915061b0a3c935fb9
Author: Steffen Ritter
Date: Thu Apr 12 21:05:05 2012 +0200
[BUGFIX] Usability improvements for Media Element

Final adaptions to the Media Element to reduce the UI to the
neccessary stuff and better distinguish between HTML5 and normal
rendering.

Change-Id: I2d377156420a0a8ea47888fd62e415829fba1f40
Fixes: #35921
Releases: 4.7,6.0
Reviewed-on: http://review.typo3.org/10358


Related issues

Related to TYPO3 Core - Feature #37939: displayCond should allow multiple conditions/checksClosed2012-06-12

Actions
Related to TYPO3 Core - Feature #18211: Array of display conditions for TCA fields instead of 1 stringClosed2008-02-14

Actions
#1

Updated by Frans Saris over 7 years ago

  • Target version set to 7.2 (Frontend)
  • Is Regression set to No
#2

Updated by Benni Mack about 7 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)
#3

Updated by Susanne Moog almost 7 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#4

Updated by Riccardo De Contardi almost 7 years ago

  • Status changed from New to Closed

I close this because the mediace extension will soon be removed from core, without backporting.

If you think that this is the wrong decision, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

#5

Updated by Stefan Neufeind almost 7 years ago

If EXT:mediace would become non-core, I expect it will get a separate forge-project then and people responsible for it? If so, shouldn't the issue be moved over to there instead, since it's still valid?

Also available in: Atom PDF