Project

General

Profile

Actions

Feature #38844

closed

Epic #92641: felogin feature collection

Add code list to felogin

Added by Arno Dudek almost 12 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
-
Start date:
2012-07-10
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

I request to have a code-list again in felogin.

In the current project I'm using felogin with salted password (v6.0.0alpha2). On the site the loginbox is on every page (per TypoScript) and next I have a single page with the felogin plugin for the forgotten password or error redirect.

A click on the "Password forgotten" link on the widget of every page, brings me to the page with the felogin plugin. You can guess what happen now. The widget get's the same content as the plugin.

Normally it was possible to set the widget as raw HTML. But this ist not possible using salted password.

I suggest to use a code list in the settings, where the diffrent templates can be selected.

So if TS is set to

plugin.tx_felogin_pi1.code = login,logout

And the current action is "Password forgotten", than it should fallback to login if the user is logged out or fallback to logout if the user is logged in.

Thanks a lot!


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Feature #29565: It is not possible to force felogin into a certain display modeClosed2011-09-08

Actions
Related to TYPO3 Core - Bug #26910: forgot does not work with more than one login form on one pageClosed2011-05-19

Actions
Actions #1

Updated by Mathias Schreiber over 9 years ago

  • Category set to felogin
Actions #2

Updated by Riccardo De Contardi over 8 years ago

  • Status changed from New to Needs Feedback

Umm I am very sorry for this late answer, and maybe I am wrong, but... can't a Typoscript condition be used here?

Actions #3

Updated by Arno Dudek over 8 years ago

Actually I don't know if the problem still exists. I think a TS condition will not help here, cause it was not possible to define the "template" by TS. The widget was defined by TS – it's simmilar to the login box on typo3.org in the top right. The password forgotten was a content element. On click "password forgotten" you see the password forgotten template in the content element and in the widget on the top right.

Actions #4

Updated by Riccardo De Contardi over 8 years ago

I Guess that the problem is still there;
the only workaround I could think of at the moment is (if possible) to remove the widget on the page with the login content element (that IMO could be useful from the usability point of view)

Actions #5

Updated by Alexander Opitz about 8 years ago

  • Status changed from Needs Feedback to New
Actions #6

Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50793

Actions #7

Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50793

Actions #8

Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50793

Actions #9

Updated by Gerrit Code Review over 7 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50793

Actions #10

Updated by Gerrit Code Review over 7 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50793

Actions #11

Updated by Gerrit Code Review over 7 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50793

Actions #12

Updated by Gerrit Code Review over 7 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50793

Actions #13

Updated by Gerrit Code Review over 7 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50793

Actions #14

Updated by Mona Muzaffar about 7 years ago

  • Related to Bug #26910: forgot does not work with more than one login form on one page added
Actions #15

Updated by Gerrit Code Review over 6 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50793

Actions #16

Updated by Gerrit Code Review over 6 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50793

Actions #17

Updated by Georg Ringer about 6 years ago

  • Related to Epic #84262: [FEATURE] Update felogin to extbase added
Actions #18

Updated by Jan Stockfisch almost 6 years ago

  • Parent task set to #84262
Actions #19

Updated by Susanne Moog over 5 years ago

  • Status changed from Under Review to Accepted

Review was abandoned.

Actions #20

Updated by Markus Klein over 3 years ago

  • Parent task changed from #84262 to #92641
Actions #21

Updated by Benni Mack almost 3 years ago

  • Status changed from Accepted to Needs Feedback

Do you still need this change with TYPO3 v10 and the Extbase plugin?

Actions #22

Updated by Benni Mack over 2 years ago

  • Status changed from Needs Feedback to Closed

I close this issue now due to lack of feedback after 3 months. Let me know if you think this decision is wrong, so I will re-open the ticket.

Actions

Also available in: Atom PDF