Bug #39416

Contentelement "MEDIA" don't works with Typ "AUDIO"

Added by Stefan Froemken over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Frontend
Target version:
Start date:
2012-07-31
Due date:
% Done:

100%

TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello TYPO3-Coreteam,

I have created a contentelement MEDIA with type "AUDIO". I have also assigned a MP3-file. After saving this element I saw in the sourcecode of my Frontend a new script SWFobject.js. Just below I can find an ID definition. And in my Contentarea I find a DIV-Tag with the same ID which is defined in the header part.

So...everything seams to be correct, but there is no player an my Frontend. The DIV-Tag has only the id defined, but it has no content. There is also no content if you look at it with help of FireBug.

I have tested the same file on TYPO3 4.6.7. There is no problem with the file. I have updated my system to TYPO3 4.7.2 and the player disappears from the frontend. I changed staticTemplate cssStyledContent to Version 4.6: But the player does not appear.

Stefan

39416.patch View - Patch (912 Bytes) Christoph Gerold, 2012-09-01 15:46


Related issues

Related to TYPO3 Core - Bug #41280: Media Element selecting files via wizard fails Closed 2012-09-23
Related to TYPO3 Core - Bug #68546: Content element "MEDIA" doesn't work with type "Audio" Closed 2015-07-27

Associated revisions

Revision 3055538c (diff)
Added by Francois Suter over 7 years ago

[BUGFIX] MEDIA element ignores audio fallback

In TYPO3 4.7 the field name containing the reference to an audio
file was changed in the MEDIA element, but the renderers were not
adapted (except the flowplayer). Other renderers must also consider
"audioFallback".

Additionally for the QT renderer, the type must be evaluated
a bit earlier, so that it can be used for audio fallback calculation.

Change-Id: Ie00d5fafc780e53fb44c02f0ff2ade45359f1bcc
Resolves: #39416
Releases: 4.7
Reviewed-on: http://review.typo3.org/15412
Reviewed-by: Lorenz Ulrich
Tested-by: Lorenz Ulrich
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

Revision c07cd400 (diff)
Added by Andreas Schütte about 7 years ago

[BUGFIX] Media element not working with FAL

With FAL the path to a file is no longer used,
instead the UID to the specific file is used,
prefixed with "file:"

This patch just adds a check if the filename
starts with "file:" and if so load the specific FileObject
to retrive the url. This check is done before all others,
because FAL should be the default file handler.
Additionally use explode() first to get the filename
if an editor adds (non used)
link parameters: file:740 _blank media-title

This fixes also the problem with audio files mentioned in #39416,
using the same patch.

Resolves: #41280
Related: #39416
Releases: 6.0, 6.1
Change-Id: Ibec6cefda54b6e136c0d5ae43c67ef2eea3b1bb8
Reviewed-on: https://review.typo3.org/18228
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Anja Leichsenring
Tested-by: Anja Leichsenring
Reviewed-by: Marco Huber
Tested-by: Marco Huber
Reviewed-by: Stefan Neufeind
Reviewed-by: Mattias Nilsson
Tested-by: Mattias Nilsson
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision b9d7fea6 (diff)
Added by Andreas Schütte about 7 years ago

[BUGFIX] Media element not working with FAL

With FAL the path to a file is no longer used,
instead the UID to the specific file is used,
prefixed with "file:"

This patch just adds a check if the filename
starts with "file:" and if so load the specific FileObject
to retrive the url. This check is done before all others,
because FAL should be the default file handler.
Additionally use explode() first to get the filename
if an editor adds (non used)
link parameters: file:740 _blank media-title

This fixes also the problem with audio files mentioned in #39416,
using the same patch.

Resolves: #41280
Related: #39416
Releases: 6.0, 6.1
Change-Id: Ibec6cefda54b6e136c0d5ae43c67ef2eea3b1bb8
Reviewed-on: https://review.typo3.org/19002
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Stefan Froemken over 7 years ago

There are some people who can confirm this bug. There is a little curious workaround:
Create a new video (type "VIDEO") and instead of inserting a video file insert an audio file. After saving you choose type "AUDIO". The input element for the audio is empty now, but the file will be displayed and is playable in Frontend.

Steffen Ritter has programmed a coreupdate script for flexformvalues: class.tx_coreupdates_mediaflexform.php. In method "performUpdate" he keeps mmFile for sVideo, but moves mmFile for type "AUDIO" to Key "mmAudioFallback".

I have searched the whole TYPO3-Sources for "mmAudioFallback", but there is no other PHP-File handling "mmAudioFallback".
Please have a look into tslib_content_Media.php. As you can see, there is an use of mmFile, but no mmAudioFallback.
So in my kind of view, you have forgotten to insert a condition from where the file comes from.

Stefan

#2 Updated by Björn Pedersen over 7 years ago

The bug must be caused by something else:
Line 98 in typo3/sysext/cms/tslib/content/class.tslib_content_media.php ahs:
$audioFallback = $this->doFlexFormOverlay($conf, 'audioFallback');

doFlexFormOverlay changes the first character to uppercase and then prepends 'mm'.

So this is gives the correct field name.

#3 Updated by Christoph Gerold over 7 years ago

The bug seems to be caused because SWFObjects takes the field $conf['file'] as input.
But the path to the audio element (Path or URL to fallback audio source (Flash or QuickTime)) is saved to $conf['audioFallback'].

Added a Patch for it.

#4 Updated by Francois Suter over 7 years ago

The problem is indeed that audio files were move to their own properties, but that most renderers haven't been adapted. Only the FLOWPLAYER takes them correctly into account. So I think the correct solution is to adapt the other players to use the "audioFallback" property like the FLOWPAYER does. I'll give it a spin.

#5 Updated by Francois Suter over 7 years ago

  • Status changed from New to Accepted
  • Assignee set to Francois Suter
  • Target version set to 4.7.5

I have a working patch locally for the SWFOBJECT. I need to adapt it to the other renderers before submitting it. And checking if the bug also exists in current master.

#6 Updated by Francois Suter over 7 years ago

I have a working patch locally for the SWFOBJECT. I need to adapt it to the other renderers before submitting it. And checking if the bug also exists in current master.

#7 Updated by Gerrit Code Review over 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/15412

#8 Updated by Francois Suter over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Sabine Deeken about 7 years ago

strange, this bug seems to be solved, but the Problem exists (still/again?)
TYPO3 6.04, PHP5.4
Audio works with Stefans Workaround (video, then change to audio, with the absolute path; not FAL)

#10 Updated by David Gurk almost 7 years ago

This bug is still there. Testet with TYPO3 CMS v6.1.1. The workaround from Stefan Froemken is still working.

#11 Updated by Werner Trunk about 5 years ago

I can confirm this also in 6.2.9

Insert element switch to audio , insert file path per Element Browser /FAL = no FE output

Insert media video: switch on html 5 > add Video sources for HTML5 > leave path empty > save > switch to audio > insert audio file path per Element Browser /FAL = works.
Result: html 5 audio canvas, not tested with flash.

#12 Updated by Mathias Bolt Lesniak over 4 years ago

Hi!

I can confirm this appears to be true also in 6.2.14. The status of this issue should not be "Resolved".

- Mathias

#13 Updated by Stefan Neufeind over 4 years ago

  • Is Regression set to No

Since the issue here is very old, please file a new one with up-to-date details. You might of course want to link to this one here.

#14 Updated by Mathias Bolt Lesniak over 4 years ago

Hi!

I have opened a new issue: #68546

- Mathias

#15 Updated by Clemens Riccabona over 3 years ago

Stefan Froemken wrote:

There are some people who can confirm this bug. There is a little curious workaround:
Create a new video (type "VIDEO") and instead of inserting a video file insert an audio file. After saving you choose type "AUDIO". The input element for the audio is empty now, but the file will be displayed and is playable in Frontend.

It is just ridiculous, but I have the same problem with the EXACTLY same workaround working on TYPO3 6.2.10 ...
Unbelievable ...

#16 Updated by Clemens Riccabona over 3 years ago

Clemens Riccabona wrote:

Stefan Froemken wrote:

There are some people who can confirm this bug. There is a little curious workaround:
Create a new video (type "VIDEO") and instead of inserting a video file insert an audio file. After saving you choose type "AUDIO". The input element for the audio is empty now, but the file will be displayed and is playable in Frontend.

It is just ridiculous, but I have the same problem with the EXACTLY same workaround working on TYPO3 6.2.10 ...
Unbelievable ...

erhm, indeed i meant 6.2.26 ... sry ...

#17 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF