Project

General

Profile

Actions

Bug #40091

closed

Previewing a page in frontend disables all enabled fields, including workspaces

Added by Armin Vieweg almost 12 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
-
Start date:
2012-08-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When you have several pages which are disabled and make a preview to one of them, you'll see the others in the navigation, as well. Furthermore the workspace, which is i.e. limited to one of these pages, will not be respected anymore, too.

Example:
I create a new page, which should not be displayed in frontend. So I deactivate it. Then I create a backend user which may access just this page (and subpages). Addionally I create a workspace, for this user and this page. The user may not publish to live.

I repeat this for several new pages and users.

Each user should not be able to see the changes of the other users, unless it has been published to live.

Generally this works, but if one of the pages is disabled - and the user does a preview on it - he will see not only all other disabled pages of his workspace - he'll see all pages, of all workspaces. And this does not fit my requirement in the paragraph before, because he can see everything.

I hope I've described the bug cleary and you are able to fix it. Otherwise I'd like to answer your questions.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #33392: showHidden flag in tslib_fe is not "workspaces aware"Closed2012-01-23

Actions
Actions #1

Updated by Armin Vieweg almost 12 years ago

I have tested it also with latest TYPO3 4.7 version and the bug still exists. But still on first level which the logged in user may see. On deeper levels it works normally.

Actions #2

Updated by Steffen Gebert almost 12 years ago

  • Project changed from TYPO3 Core to 624

I think this is a workspaces issue.

Actions #3

Updated by Timo Webler about 11 years ago

  • Assignee set to Armin Vieweg

Maybe fixed with #33392. Fixed in version 4.5.26. Can you test it?

Actions #4

Updated by Michael Stucki over 10 years ago

  • Category set to Workspaces
Actions #5

Updated by Michael Stucki over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
Actions #6

Updated by Mathias Schreiber over 9 years ago

  • Target version set to 7.5
Actions #7

Updated by Benni Mack over 8 years ago

  • Target version changed from 7.5 to 7 LTS
Actions #8

Updated by Mathias Schreiber over 8 years ago

  • Target version deleted (7 LTS)
  • Is Regression set to No
Actions #9

Updated by Benni Mack almost 4 years ago

  • Status changed from New to Needs Feedback

The workspaces issue should be resolved by now. If you preview a hidden page, and there are other pages that are hidden as well, TYPO3 enables the "show hidden content" and "show hidden pages" flags automatically (which can also be configured via Admin Panel), which is expected behavior currently. However, we could mark this as a breaking change to only preview the current page (but then: including current content as well?) which is hidden, and not respecting this in the menus etc.

What do you think?

I read from people using the "hidden" pages to simulate some kind of "poor-mans-workspaces" to preview a new state of the website, so we might make some people unhappy (but that's life).

Actions #10

Updated by Christian Kuhn over 2 years ago

Closing: We worked quite a bit on workspace preview state in v11 an resolved various issues in this area. Please create fresh issues if we missed something.

Actions #11

Updated by Christian Kuhn over 2 years ago

  • Status changed from Needs Feedback to Closed
Actions

Also available in: Atom PDF