Bug #41628

Epic #80535: Leftover tasks about javascript in TYPO3 Backend

Log D+D moving of pages in history

Added by Felix Kopp about 8 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend JavaScript
Start date:
2012-10-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Remote Sprint

Description

The moving of pages via drag and drop in pagetree is not logged to the history table. This should be done

#1

Updated by Thomas Löffler about 8 years ago

It is also not logged to the history table if I change the order of the pages in the List view.
Title changes are logged.

#2

Updated by Steffen Gebert about 8 years ago

  • Status changed from New to Accepted
#3

Updated by Mathias Schreiber almost 6 years ago

  • Target version set to 7.4 (Backend)
  • Is Regression set to No
#4

Updated by Frank Naegler over 5 years ago

  • Sprint Focus set to Remote Sprint
#5

Updated by Frank Naegler over 5 years ago

think the problem is anywhere in DataHandler. I tried to use updateDB which calls setHistory but this not work because $this->historyRecords is not set before.

#6

Updated by Susanne Moog over 5 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#7

Updated by Benni Mack about 5 years ago

  • Target version changed from 7.5 to 7 LTS
#8

Updated by Mathias Schreiber about 5 years ago

  • Target version deleted (7 LTS)
  • Parent task set to #55575
#9

Updated by Riccardo De Contardi over 3 years ago

  • Category set to Backend JavaScript
  • Target version set to Candidate for Major Version
  • Parent task changed from #55575 to #80535
#10

Updated by Benni Mack about 3 years ago

  • Status changed from Accepted to Closed

This works now, but we only need to render how the history module should be displaying this stuff now (which I think should be a separate ticket)

Also available in: Atom PDF