Bug #26615

Many stage changes do NOT send email notifications

Added by Simon Schaufelberger over 8 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Workspaces
Target version:
-
Start date:
2011-05-04
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have created a page and one content element in workspace. I am the workspace owner and member at the same time so all emails will come to me.
I changed to workspace module and sent all changes to the next stage using the arrows to the right on every item in the list. On every change I got the popup to send the notification email to myself which i confirmed. At the end I only got a few of them. Some stage changes just don't send an email...


Related issues

Related to TYPO3 Core - Bug #36278: Comments entered in the publishing stage are not displayed. Closed 2012-04-18
Related to TYPO3 Core - Bug #33383: Add Comments when Publishing Closed 2012-01-23
Related to TYPO3 Core - Bug #42948: Catchable fatal error using the developing area Closed 2012-11-14
Related to TYPO3 Core - Bug #42830: Notifications sent on publish when stagechg_notification=0 Closed 2012-11-10

Associated revisions

Revision df8abc0e (diff)
Added by Marco Bresch about 7 years ago

[BUGFIX] Sent notification when changes are published

Currently only stage changes trigger notification emails,
this change also invokes the notifications when changes are
swapped /published. The comments are also stored in sys_log.

Change-Id: I78c9de426e1994f2de649465cf6743f56405604d
Resolves: #26615, #33383
Branches: 4.5, 4.6, 4.7, 6.0
Reviewed-on: http://review.typo3.org/4518
Reviewed-by: Marco Bresch
Tested-by: Marco Bresch

Revision 3492cf61 (diff)
Added by Tolleiv Nietsch about 7 years ago

[BUGFIX] Sent notification when changes are published

Currently only stage changes trigger notification emails,
this change also invokes the notifications when changes are
swapped /published. The comments are also stored in sys_log.

Resolves: #26615, #33383
Branches: 4.5, 4.6, 4.7, 6.0

Change-Id: I7d90d62c4d8c58b621246d6da9a8e0fdaaf3b423
Reviewed-on: http://review.typo3.org/15544
Reviewed-by: Marco Bresch
Tested-by: Marco Bresch

Revision 74b8e3df (diff)
Added by Marco Bresch about 7 years ago

[BUGFIX] Sent notification when changes are published

Currently only stage changes trigger notification emails,
this change also invokes the notifications when changes are
swapped /published.

Change-Id: Ib2158e0532fd5eb714a300424970354cd187226c
Resolves: #26615, #33383
Branches: 4.5, 4.6, 4.7, 6.0
Reviewed-on: http://review.typo3.org/4519
Reviewed-by: Marco Bresch
Tested-by: Marco Bresch

Revision 6c8f9a47 (diff)
Added by Marco Bresch about 7 years ago

[BUGFIX] Sent notification when changes are published

Currently only stage changes trigger notification emails,
this change also invokes the notifications when changes are
swapped /published. The comments are also stored in sys_log.

Resolves: #26615, #33383
Branches: 4.5, 4.6, 4.7, 6.0

Change-Id: Ib2158e0532fd5eb714a300424970354cd187226c
Reviewed-on: http://review.typo3.org/15620
Reviewed-by: Marco Bresch
Tested-by: Marco Bresch

History

#1 Updated by Michael Bakonyi over 8 years ago

I can confirm this issue but only regarding the last step "Publish".

#2 Updated by Oliver Hader over 8 years ago

  • Status changed from New to Needs Feedback
  • TYPO3 Version set to 4.5

Thanks for your report. Can you please tell which stages of the "some stages" are affected (only publish)? Which TYPO3 version do you use (I guess 4.5)?

#3 Updated by Simon Schaufelberger over 8 years ago

Yes, only the publish stage is affected. I use 4.5.2

#4 Updated by Dani no-lastname-given over 8 years ago

I also can confirm this issue, only the last step "publish" is affected (Typo3 4.5.3)

#5 Updated by Jigal van Hemert over 8 years ago

Just encountered the same problem on the last step in TYPO3 4.5.3

#6 Updated by Michael Klapper over 8 years ago

Jigal van Hemert wrote:

Just encountered the same problem on the last step in TYPO3 4.5.3

That is true. On the last step "Publish" no emails are send at the moment.
But can you please describe on which situation emails are mission beside the last step?

#7 Updated by Tolleiv Nietsch over 8 years ago

  • Assignee set to Tolleiv Nietsch

#8 Updated by Mr. Hudson over 8 years ago

Patch set 1 of change I78c9de426e1994f2de649465cf6743f56405604d has been pushed to the review server.
It is available at http://review.typo3.org/4518

#9 Updated by Mr. Hudson over 8 years ago

Patch set 1 of change Ib2158e0532fd5eb714a300424970354cd187226c has been pushed to the review server.
It is available at http://review.typo3.org/4519

#10 Updated by Tolleiv Nietsch over 8 years ago

  • Status changed from Needs Feedback to Under Review
  • Target version set to 4.5.6

#11 Updated by Simon Schaufelberger about 8 years ago

can somebody please provide a fix for that as it is not yet in the core?

#12 Updated by Tolleiv Nietsch about 8 years ago

@Simon - there's a patch waiting for review - what else do you expect?

#13 Updated by Henrik Ziegenhain over 7 years ago

With 4.5.13 I can confirm this issue.

It seems that the last (publish) stage and custom stages are affected.

I applied patch http://review.typo3.org/4519 but it does not resolve the problems for me. Can anybody confirm this?

#14 Updated by Henrik Ziegenhain over 7 years ago

The workspace notifitations are not working if [MAIL][defaultMailFromName] in install tool is set.

Clearing my custom MailFromName solved the problem.

#15 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/4518

#16 Updated by Ernesto Baschny over 7 years ago

  • Target version deleted (4.5.6)

Not targeting any specific TYPO3 version yet

#17 Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/4518

#18 Updated by Gerrit Code Review over 7 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/4518

#19 Updated by Gerrit Code Review over 7 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/4518

#20 Updated by Gerrit Code Review over 7 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/4518

#21 Updated by Heiko Kromm about 7 years ago

Patch works for me, please add it to master.

#22 Updated by Gerrit Code Review about 7 years ago

Patch set 7 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/4518

#23 Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch version_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/15544

#24 Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch 4.6 has been pushed to the review server.
It is available at http://review.typo3.org/15620

#25 Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch 4.5 has been pushed to the review server.
It is available at http://review.typo3.org/4519

#26 Updated by Marco Bresch about 7 years ago

  • Status changed from Under Review to Resolved

Merged for 4.5, 4.6, 4.7 and 6.0 (master)

#27 Updated by Marco Bresch about 7 years ago

  • Status changed from Resolved to Accepted
  • Assignee changed from Tolleiv Nietsch to Marco Bresch

Reopend. It seems there are some more adjustments necessary.

#28 Updated by Gerrit Code Review about 7 years ago

  • Status changed from Accepted to Under Review

Patch set 3 for branch 4.5 has been pushed to the review server.
It is available at http://review.typo3.org/4519

#29 Updated by Gerrit Code Review about 7 years ago

Patch set 4 for branch 4.5 has been pushed to the review server.
It is available at http://review.typo3.org/4519

#30 Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch 4.6 has been pushed to the review server.
It is available at http://review.typo3.org/15620

#31 Updated by Marco Bresch about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

submitted for 4.5, 4.6 and 4.7 too

#32 Updated by Bart Dubelaar about 7 years ago

Thanks Marco for pushing this one through!

#33 Updated by Myriam Bernard almost 7 years ago

With Typo3 4.6.15 email are not send when the stage is send to a stage I've add in custom workspace.
When the content is send to stage "ready to publish" an email is send ...

#34 Updated by Michael Stucki about 6 years ago

  • Category set to Workspaces

#35 Updated by Michael Stucki about 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

#36 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF