Project

General

Profile

Actions

Bug #45056

closed

History doesn't show page deletions for non-admin BE user

Added by Andrew Moore over 11 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2013-02-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When accessing the history information on a page which has had sub-pages deleted, as a non-admin user, the sub page deletions no longer show up in the history changelog. They used to show up in a previous versions of TYPO3 (the version we used previously was 4.2.17).

Steps to reproduce:

- Log into BE as non-admin user
- Create a page (parent)
- Create a sub page of parent page (child)
- Delete child page
- Look at record history on parent page, ensure "Show sub elements" and "Show inserts/deletes of records" settings are set to yes

The deletion of the child pages is not shown in the log.

We use this functionality to allow our users to easily "undelete" pages.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Feature #79335: Add pageaction "clear recycler" to context menu of recycler (doktype 255)Closed2017-01-16

Actions
Actions #1

Updated by Thorsten Kahler over 11 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Andrew Moore
  • Priority changed from Must have to Should have

Are you sure that it works at all? On my 4.5 and 6.0 installations it doesn't either work for admin users.

Priority set to "should have" because it's still possible to restore the page record by the "Recycler" extension.

Actions #2

Updated by Jigal van Hemert almost 11 years ago

  • Status changed from Needs Feedback to New
  • Assignee deleted (Andrew Moore)
Actions #3

Updated by Mathias Schreiber over 9 years ago

  • Target version changed from 4.7.8 to 7.4 (Backend)
  • Is Regression set to No
Actions #4

Updated by Susanne Moog almost 9 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #5

Updated by Benni Mack over 8 years ago

  • Target version changed from 7.5 to 7 LTS
Actions #6

Updated by Mathias Schreiber over 8 years ago

  • Target version deleted (7 LTS)
Actions #7

Updated by Riccardo De Contardi about 8 years ago

  • Tracker changed from Bug to Feature
  • Priority changed from Should have to Could have

I tried with 4.7, 6.2 and the latest master, with both admin and editor users, and in history the delete of a subpage is never shown.

- I am setting this as a "feature"
- I am setting this as "could have" because recycler is accessible for editors and is the natural way to restore pages or content

Actions #8

Updated by Frans Saris almost 8 years ago

  • Tracker changed from Feature to Bug
  • TYPO3 Version set to 7
  • Is Regression set to No

Set it back to bug as IMO this more a bug then a missing feature

Actions #9

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54580

Actions #10

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54579

Actions #11

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54580

Actions #12

Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54580

Actions #13

Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54579

Actions #14

Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54580

Actions #15

Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54579

Actions #16

Updated by Helmut Hummel over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #17

Updated by Gerrit Code Review over 6 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54610

Actions #18

Updated by Helmut Hummel over 6 years ago

  • Status changed from Under Review to Resolved
Actions #19

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions #20

Updated by Rene Tobias over 3 years ago

Helmut Hummel wrote:

Applied in changeset 9ef9c10b8af9d6c201e3c6a8ac372f4db6f0cf51.

Hey, i still get this problem on 9.5 :/

Actions

Also available in: Atom PDF